Direct NAS Reading & Writing - How?


I’ve probably been googling the wrong words as I can’t find a way to set up the following.

I’ve been able to get access to our Netgear NAS, I can browse it, copy files etc. just fine.

But I don’t have “direct access” in as far as, Open Office won’t open any files residing on the NAS, neither can I save directly to the NAS form a program and when I get a “Browse for File” form field on a website (eg attachments in GMail etc.), I can’t browse to the NAS either.

My XP box does do all of this, either through my mapped network drive or even through browsing the network.

How can I make openSuse 11.2 use the NAS with my login credentials as if it was a local disk?

I added this line to the bottom of /etc/fstab

// /NAS cifs guest,_netdev 0 0

Then I also had to create the /NAS directory in openSUSE. This folder has to already exist so that it mounts the NAS share in that folder.

It may or may not automatically mount every time you log in. I had to create a script in my /home/wilson/kde4/.Autostart/ to mount the share automatically. This has to be run as root, and has to be set up in sudoers. I named it and made it executable.

/bin/sleep 10
/bin/mount -a

Good luck.


With your answer, I was able to Google around a bit better.

It’s a ReadyNAS which supports NFS. According to many sources, I believe NFS is the best way for linux to mount something as if it was local.

This thread for example, described part of my problem. OpenOffice indeed is a biatch over smb://

openoffice cannot open or save files on the network -

He got it working with NFS.

So I added this in /etc/fstab as root: /mnt/Sharename nfs auto 0 0

And indeed did mkdir /mnt/Sharename

On the ReadyNAS, I enabled write access for my IP under the NFS tab. If I also enter my IP as “Root privilige-enabled hosts” I can access the Share folders as root. Not as my normal user.

My NAS shares require user authentication.

How can I set up fstab for nfs so I can pass on the user credentials?

Never mind, got it working.

I had to match the openSuse user and uid with the NAS user and UID.

Now it mounts like this: /mnt/Sharename nfs auto 0 0

In Dolphin I can now right-click under Places and “Add Entry” and put location as “/mnt/Sharename/”

Now I can open files directly in OpenOffice. I can also save to it directly. For convenience, I added a NAS folder in my user home and added a symlink in it to each sharename in the /mnt folder.

My NAS doesn’t do NFS, so I am no help there. Good to see you got it working.