dinovo keyboard not workig on 12.2

dinovo keyboard not workig, logitech trackball also not working.
on suse 12.1 everything works
on last kubuntu everything works
on suse 12.2 the keyboard works only at level 3, despite being listed and selected.
in kde
hier some output:

msi_user@linux-dcb1:~> dmesg | grep input
3.399770] input: Logitech Logitech BT Mini-Receiver as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4.1/2-
3.400102] generic-usb 0003:046D:C713.0003: input,hidraw2: USB HID v1.11 Keyboard [Logitech Logitech BT Mini-Receiver] on usb-0000:00:1d.0-
3.562863] input: Logitech Logitech BT Mini-Receiver as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4.1/2-
3.563482] logitech 0003:046D:C714.0004: input,hiddev0,hidraw3: USB HID v1.11 Mouse [Logitech Logitech BT Mini-Receiver] on usb-0000:00:1d.0-

has somebody some idea?
thank you!

Does this fix work? Ubuntu 12.04 LTS (Precise Pangolin) and Logitech Dinovo Edge Keyboard Issue

thanks ardvidjaar!
well, I did that as first thing, that is a “mainstream” bug, that correction is anyway necessary.
well, all great achivements are riched thru catastrophes.

Sorry, I do not understand - did it help or not?

arvidjaar, unfortunately don’t!
it looks like a distribution bug at graphic level. I also understand that this bug was already discovered and there is no known solution! the moderators keep silent :slight_smile: the only option: delete the installation and goodbye opensuse 12.2

First: the moderators are not the almighty omniscient.
Second: how can we help you if you leave?
Third: things must have worked during install, so it should work. Conclusion: something must have changed after install.

hi knurpht!
it was never in my intention express any kind of criticism on moderators behalf! if I gave a such impression I really apologize.
well, on my desk I use a quite powerful laptop connected with desktop peripherals: monitor keyboard and trackball (among other devices). on install time, I used of course the internal laptop peripherals :.
in addition I don’t need at this stage to keep that not working installation: first, I have to understand a bug, kind and localization. only after that I can take in consideration some attempting. my deletion doesn’t mean a surrender! so, in my free time I still look for a solution.
at this point:

  • logitech bluetuth trackballs work everywhere out of the box, but on 12.2 don’t: really surprising and “buggy”.
  • in text mode the keyboard works 100%, the trackball would possibly also work.
  • permissions: there is no problem because also after startx the devices stop working.
    possible conclusion: xorg problem! and here:
  • installing the nvidia proprietary drivers didn’t help.
  • importing the xorg.conf from my perfectly working 12.1 didn’t help.
    an fglrx output from somebody on trouble shows:

(WW) evdev: Logitech Logitech BT Mini-Receiver: ignoring absolute axes.
(WW) evdev: Logitech diNovo Keyboard: ignoring absolute axes.
(WW) evdev: Logitech diNovo Keyboard: ignoring absolute axes.

that is a possible start point! let me first see deeper.

No offense taken :), from time to time I just have to point out what things are like.

I agree that this must be a matter of X, or the desktop, but rather X.
Questions: did it all work before the NVIDIA driver was installed? Does the keyboard/trackball work when you boot in failsafe mode?
Most important: Did you try changing the keyboard in KDE - Systemsettings - Input devices - Keyboard? It defaults to Generic, and yours will as well, since you installed that way. In the dropdownlist I see the dinovo and dinovo edge keyboards. I suggest you select it, apply, then try and if it does not work, reboot and log back in. Report what happened.

Hi Knurpft, Hi arvidjaar,
If the solution for a problem can’t be found often the reason is that we are dealing with two or more problems together!

  • basically arvidjaar is right, after the turnaround with “/lib/udev/rules.d/97-bluetooth-hid2hcl.rules” where under “# Logitech devices” KERNEL==“hiddev*” is changed to KERNEL==“hidraw*”, the keyboard works.
    However, it didn’t work on my laptop!.
  • The next bug concerns an USB switch which I use to connect/disconnect all my USB peripherals. Such hub uses a widely used chip, the “lsusb” output is
    Bus 002 Device 003: ID 058f:6254 Alcor Micro Corp. USB Hub
    All the attached peripherals are normally listed in lsusb and dmesg, but they do not work under X. Belive or not! This time I opened “71-seat.rules” in the above mentioned folder and commented out the first line in the section “# Mimo 720, with integrated USB hub, displaylink graphics, and e2i touchscreen”. Just a try, but it works 100%. Under 12.1 such a line doesn’t exist and the hub works normally. I don’t have a touchscreen which could be affected by this change.
  • At this point I completed the installation also configuring the software, and discovering again a bug, this time already present in 12.1. Some wifi works badly disconnecting or even deauthenticating intermittently.I have an Intel wireless and I am subsequently affected by this bug. The problem is software and not hardware related (Dell). Listen to internet radio longer as for a couple of minutes becomes impossible! Under 12.1 I found as only solution exchanging the official kernel for the “herbster0815” one. After that the bug disappears.This time I had to do once more the same thing for the same reason. Don’t ask me what is wrong, the kernel or the driver modules coming with.
  • I find cairo-dock very handy: by changing from version 2.5 to 3.x this bar must be reconfigured from scratch to avoid a brutal cpu load. Anyway, I saved one hour of work copying just the launchers :). The bar must be put manually in the desktop autostart and not in the home /.config/autostart directory, what would affect the sound applets, in my case phonon is not yet started!
    No further relevant informations.
    Thanks not only for help but in particular for your “human participation”, what helps more as some technical advice!
    Knurpft, now my 12.2 installation is even backed up, despite I still keep also the old 12.1, never know! :slight_smile:
    friendly, Capodastro

I’m impressed. Really. Thank you for sharing this, this explains what happens and also where to look next time. What happens is, there are external devices with own display/touchpad so systemd tries to create new “seat” (i.e. workplace) for them. So other X server are not allowed to use them.

Could you paste output of “lsusb” and “lsusb -t” (in tag code please)? I would like to check whether you have this device or not; if not, upstream systemd contains more specific rules, so we may open bug report to request them to be included.

Thank you!

hi Knurpht, http://forums.opensuse.org/avatars/knurpht.gif?dateline=1317159322](http://forums.opensuse.org/members/knurpht.html) - (nice thing, good to steal),
well, in my young time I was educated in a university for doing research: until today is still my habit to try all combinations. That was also the reason for deleting the installation and do later a clean work on a fresh backed up system.

  • The bug seams to be graphic driver independent. I attempted first with nouveau and it didn’t work neither. However, after the “diNovo correction” the keyboard worked, but only in text mode, runlevel 3. I assume that in text mode the trackball was also working. That concerns also both, nvidia and nouveau.
    I have on my HDD a partmagic iso and a gentoo sysrescuecd iso. I start the images using grub. On both distributions keyboard and trackball work out the box, with no need of corrections. The same concerns TinyCore, a lovely small ( they say “parsimonious”) distribution which I also keep on my HDD. I will take a look and tell you what they did. On Xbuntu the diNovo correction is necessary, but not the “hub” one. Same situation on suse 12.1. After that I regard the “mainstream” as heavy issue, being imported solution and mistakes on the same time. And possibly we wait for ubuntu bringing a solution!

  • Yes, I tried in failsafe, with both, nvidia and nouveau, but it didn’t work.

  • Yes, under KDE I selected diNovo edge as keyboard, no success. I also checked on another small preinstalled desktop and no success. Despite the evidence that the problem is in X, I kept always the best possible impartiality.

  • Generally I am astonished about the progress with 12.2! Even the speed is again improved! And the graphic quality, and the sound! Next time I will participate to the testing by the new distribution, if I was able to be tester by google in the time of gmail development I can also help a bit by suse: hardware testing requires owning or borrowing the hardware to test and I already installed suse on many laptops for computer-illiterate friends. I could check on all that machines.

  • on ubuntu they have already compiz 1.1 and emerald 9.5. As soon I have some energy (time have we always :)) I will try to compile them ( = find the packages).

  • if you have more questions just feel free, I keep always a clean copy of the installation and the restoring process takes about 15 min.

  • finally, I understand very well what means working as moderator in a such forum. I can only comment with the words of somebody who is unfortunately no longer alive:

“It is easy to be stupid and believe in the humanity.
It is easy to be intelligent and be cynic.
It is difficult to be intelligent and believe in the humanity”


hi arvidjaar, good news!!!
first of all I confess I didn’t mention really everything. in my opinion the bluetooth on my desktop was generally not working: it didn’t find either the keyboard nor my handy, that is the truth! after the “patch” the diNovo started silently working, but still the handy was undiscovered. Now, the tentation was strong and I keep a copy of the installation, I started the parted magic iso and copied the rules.d folder. in my original rules.d I replaced:

  • reboot
    the hub works 100%, but the diNovo don’t. after a few seconds kde informed me about the discovery of new devices, by scanning showed me keyboard and handy, end after selecting diNovo gave me a pin code to type on the keyboard. And done!!!
    After rebooting the connection keeps.
    Now we know what is the bug: the bluetooth system is half broken, it doesn’t find the devices and of course can’t start the authentication process. For this reason such devices don’t work under X.
    you will find parted magic ( great tool, I used it to clone a disk, suse included, and to backup all my installations.) here

Parted Magic | Free software downloads at SourceForge.net

i intend also to replace the files
if different

I am glad that you resolved your problem. I would be even more happy if you helped resolve it for all others.

I replaced:

So could you please paste these two files here so I could open bug report requesting rules to be updated in openSUSE?

ok, let do it according with your preferences. However I find better to have the whole rules.d folder. I gave you the download link and you can start the iso with the vmplayer or simply mount the iso with acetoneiso2.


This file is part of systemd.

systemd is free software; you can redistribute it and/or modify it

under the terms of the GNU Lesser General Public License as published by

the Free Software Foundation; either version 2.1 of the License, or

(at your option) any later version.

ACTION==“remove”, GOTO=“seat_end”

TAG==“uaccess”, SUBSYSTEM!=“sound”, TAG+=“seat”
SUBSYSTEM==“sound”, KERNEL==“card*”, TAG+=“seat”
SUBSYSTEM==“input”, KERNEL==“input*”, TAG+=“seat”
SUBSYSTEM==“graphics”, KERNEL==“fb[0-9]*”, TAG+=“seat”
SUBSYSTEM==“usb”, ATTR{bDeviceClass}==“09”, TAG+=“seat”

‘Plugable’ USB hub, sound, network, graphics adapter

SUBSYSTEM==“usb”, ATTR{idVendor}==“2230”, ATTR{idProduct}==“000[13]”, ENV{ID_AUTOSEAT}=“1”

Mimo 720, with integrated USB hub, displaylink graphics, and e2i

touchscreen. This device carries no proper VID/PID in the USB hub,

but it does carry good ID data in the graphics component, hence we

check it from the parent. There’s a bit of a race here however,

given that the child devices might not exist yet at the time this

rule is executed. To work around this we’ll trigger the parent from

the child if we notice that the parent wasn’t recognized yet.

Match parent

SUBSYSTEM==“usb”, ATTR{idVendor}==“058f”, ATTR{idProduct}==“6254”,
ATTR{%k.2/idVendor}==“17e9”, ATTR{%k.2/idProduct}==“401a”, ATTR{%k.2/product}==“mimo inc”,

Match child, look for parent’s ID_AVOID_LOOP

SUBSYSTEM==“usb”, ATTR{idVendor}==“17e9”, ATTR{idProduct}==“401a”, ATTR{product}==“mimo inc”,
ATTR{…/idVendor}==“058f”, ATTR{…/idProduct}==“6254”,

Match child, retrigger parent

SUBSYSTEM==“usb”, ATTR{idVendor}==“17e9”, ATTR{idProduct}==“401a”, ATTR{product}==“mimo inc”,
ATTR{…/idVendor}==“058f”, ATTR{…/idProduct}==“6254”,
RUN+="/sbin/udevadm trigger --parent-match=%p/…"

TAG==“seat”, ENV{ID_PATH}=="", IMPORT{builtin}=“path_id”

SUBSYSTEM==“input”, ATTR{name}==“Wiebetech LLC Wiebetech”, RUN+="/bin/loginctl lock-sessions"



This file is part of systemd.

systemd is free software; you can redistribute it and/or modify it

under the terms of the GNU Lesser General Public License as published by

the Free Software Foundation; either version 2.1 of the License, or

(at your option) any later version.

ACTION==“remove”, GOTO=“seat_late_end”

ENV{ID_SEAT}=="", IMPORT{parent}=“ID_SEAT”

ENV{ID_SEAT}!="", TAG+="$env{ID_SEAT}"

TAG==“uaccess”, ENV{MAJOR}!="", RUN{builtin}+=“uaccess”


And now:
finally I installed also all the bluetooth files:

Like I wrote, I got consequently a well working bluetooth system, with working device discovery, what fixes exactely the diNovo keyboard bug and much more. BUT!!!:
later I pressed by mistake th standby button and what a catastrophe by restoring. nothing more works and everything must be resetted-rebooted-reconfigured, assuming that then it will work again. opensuse shows an absolute leak of robustness concerning autentification, possibly attempting to repair bugs with a too liberal use of password requests, see what they did with wireless. for this reason I renonced to get the bluetooth working, being content just with a working dinovo keyboard.
better injured as dead.
i am also working here for evrybody, but as old suse user I don’t belive the team will fix such bugs. if you are lucky they will put in the code a remark concerning the next distribution (don’t worry, the team is not erloud to read posts :)).
the best kind of help is to make finally a couple of well structured posts, they will be well visible in google, what I find relevant because our issues concern at least also all xbuntu distros. if ubuntu will fix a bug also opensuse will do that. they call that “mainstream”.
right now, let go ahead and use for some time the fixed system. have you a better idea?

sorry, I made some confusion: the bug concerning the hub looks like 12.2 specific. may be posting the bug will be successful, just go ahead with filing this one.

Could you test updated systemd from https://bugzilla.novell.com/show_bug.cgi?id=782271?

  • I uncommented the original ominous line 71-seat.rules
    /lib/udev/rules.d/71-seat.rules- I putted what they want in
    and it seams to work 100%.
    <G>, the guys are really working there, times are better as before :slight_smile:
    in this case I am glad and happy to take back all what I wrote!
    I found there a checked box with my real name (no problem) and a 7 years old email address no longer existent: how to change that?

I made also some home work:
concerning diNovo: either patch 97-bluetooth-hid2hci.rules or overwrite the file, letting unchanged the additional 2 bluethooth files. In both cases the keyboard works, standby 100%, hibernation 100%.
after overwriting, additionally the device discovery / authentication works 100% (with some patience…)

  • the usb hub / switch improves dramatically the booting time, keeping all usb peripherals isolated.
  • all this stuff attached to my machine should make the standby / hibernation impossible, perhaps the chip is very intelligent (auto=1 or similar in the code, they were asking them self about the meaning of this value! ). Is difficult understand the chip-properties if this one is hidden in a monitor, like usually made.

And did you open bug report for it?

yes I did, I even checked all correction proposals, but my knowledge is very rudimentary.anyway the patch in /etc/… works as well as the other 2 corrections. you have forgotten answering my question in my last post, and you are certainly found about.