Dim screen after openSUSE update

I’m running openSUSE Leap 42.1 in a Virtualbox virtual machine. I had a bright screen. Then I updated my system and now I have a dim screen. None of the usual brightness controls work. Help!

Have a look at this thread (seems a regression… I don’t see it here)

Yes, I saw that thread, but I don’t know if the solution suggested there works on virtual hardware as opposed to real hardware.

I would suggest trying it to see how it goes…

How would I find out what virtual hardware I have in my virtual machine, because it could be different from my actual hardware?

With paravirtualization like what you have in VBox,
You’re using hardware CPU directly, but accessed differently than if you installed directly on metal.

Bottom line is,
You don’t have any options to configure(except tweaks), you’re basically using whatever is provided.

The only type of virtualization that allows you to emulate different CPU is QEMU.

Malcolm is basically saying that you should just try the fix to see if it works, no custom configuration on your part.

An extra complication is that those hardware keys are typically accessed using low level BIOS and kernel code. I did some research on this awhile back, and those special alt functions across the top row are typically unique to the manufacturer (there seems to not be any standards) and that code is almost always written in Microsoft Windows specific code. To enable this to work in Linux, there is a special part of the Linux kernel that contains keyboard code when a manufacturer is willing to provide it, but it’s very hit and miss whether manufacturers provide this code for various models. There is no guarantee that the code the manufacturer submits to the kernel will work in all scenarios and a virtual machine could be overlooked.

Another try which I haven’t looked into is to try to pass the keyboard combination you need to the Guest instead just typing it…


My screen is back to normal for some reason. But my wallpaper has changed, but that’s another post!