Dim Display

Screens dim after 5 minutes. All options under power management are turned off. Any Ideas?

My first idea is to ask for more info on your system. There are numerous screens out there running who knows what that go blank after just a few seconds even. So lets go for the basics;

openSUSE Version: 12.1, 12.2 for instance

Desktop Used: KDE & GNOME are two choices

Did you decide to go with 32 bit or 64 bit installation?

Tell us something about your computer and screen. Desktop, Laptop, External Monitor, just what device specifically are we blanking?

In the mean time and knowing so little, you can start looking here: https://forums.opensuse.org/english/get-technical-help-here/applications/478144-screen-goes-blank-kde-4-9-1-opensuse-12-2-a.html

Thank You for using openSUSE,

On Thu, 31 Jan 2013 02:56:02 +0000, ebitz wrote:

> Screens dim after 5 minutes. All options under power management are
> turned off. Any Ideas?

Try running:

xset -dpms

If that doesn’t help, then let us know what version of openSUSE you’re
using, and what your video hardware is.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On Thu, 31 Jan 2013 17:42:26 +0000, Jim Henderson wrote:

> On Thu, 31 Jan 2013 02:56:02 +0000, ebitz wrote:
>
>> Screens dim after 5 minutes. All options under power management are
>> turned off. Any Ideas?
>
> Try running:
>
> xset -dpms
>
> If that doesn’t help, then let us know what version of openSUSE you’re
> using, and what your video hardware is.

Oh, yes, and which desktop envrionment you’re using (GNOME, KDE, other)

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

My fault on that. I know better to include that info. In any event I did try the xset -dpms with no luck.

System Info.
Desktop (2 External Monitors)
openSUSE 12.2 (64) KDE 4.8.5(release 2)
Nvidia GTX 560 (304.64 driver)

So, just to clarify a bit further - have you have disabled ‘Dim Display’? (via System Settings >> Power Management >> Energy Saving Settings)

You should also visit your KDE screen saver and see what it is set for.

menu / Configure Desktop / Hardware / Display & Monitor / Screen Saver and either disable it or pick something that does not go blank. I like the GLMatrix one myself but if you have lots of pictures, the slide show can be neat as well. When using a screen saver, you also want to do this:

Open up Dolphin, Under View, Check Show Hidden Files and the navigate to:

http://paste.opensuse.org/view/download/95688820

Of course you will be looking in Your named /home area and not mine. Add the line shown above and save the file. This should also help. I would make this change in case you ever use the screen saver, just in case.

Thank You,

Thanks for the immediate responses. Yes, all my options are turned off, and I don’t use the screensaver option. Also I don’t have that .config file. Is it created when I turn screensaver on? Do I need it?

Neither do I.

Is it created when I turn screensaver on?

Yes.

Do I need it?

You should give it a go. I’m not experiencing the issue you describe, but then I have different graphics hardware to you.

hey deano_ferrari, thanks for your help thus far. Greatly appreciated. More issues though. I activated my screensaver setting and restarted but when I look in the .config list you mentioned earlier, no file was generated. It’s almost like the power management is having absolutely no effect on my computer what so ever. Even the dim display does no seem to do anything.

I didn’t refer to any ‘.config’ file, but James did refer to ‘kscreensaverrc’, which is located within your user’s home directory (~/.kde4/share/config/). It should have been created when you activated the screensaver (and applied the changes).

I did point you at the power management (System Settings) controls. Those settings are reflected in ~/.kde4/share/config/powermanagementprofilesrc

hi I have an externale monitor attached to my notebook, but the dimmer not work only on the external display!! can I configure the dimmer (ACPI) also for it?
thanks

@susecom
Please start a new thread and provide information about your laptop such as brand, model and graphics card.
Include the openSUSE distro version and DE such as KDE3, KDE4 or GNOME.