Digikam - Pictures in albums no longer showing

Running openSuSE 11.1 and Digikam 1.1.0 under KDE 4.4.1 with most recent updates as of today. I started digikam and all settings are still in place and database file exists same as always. All subcollections in the albums show zero pictures. Opening file manager shows all contents exists.

What gives?

Try this and see if that helps:

Goto Tools > Rebuild Thumbnails

and then choose to rebuild all. It’s going to take some time, depending on how many photos are in there, but it saved me in the past in a similar situation.

Thanks for the suggestion. I rebuilt all thumbnails, however, all
albums still show as empty with no items. :frowning:

Anyone have any more thoughts? I’m hoping I didn’t lose the database information somehow, had many geo and comments stored.

Another thing I just tried was copying the digikam database and then removed the database and let it rebuild the whole thing from scratch. Still nothing shows. I rebuilt the thumbnails database and it is 522mb in size, so obviously it sees the pictures exist but every album count shows as zero.

This didn’t happen until I updated to 4.4.1.

I posted a bug report on KDE forum and provided debug output as requested. The issue is related to kioslave for digikam albums does not start even though all packages are updated.

I tried downgrading the Digikam package down to release 9.4 from the repo-oss and presto, all album contents once again appeared with no other package changes.

I’ve tried the latest digikam 1.2 release and 4.4.2 release of KDE and still albums show as empty even though contents exist.

Is there a packaging issue on the openSuSE Repositories?

seeing the same problem (probably doesn’t help that I’m using the kde4 unstable repo)

anyone have any ideas?

when I rebuilb the db I see all the jpg’s in the building window being scanned but then there’s still nothing showing in digikam

I’m still running the 9.4 release at this point. Digikam forum claims it’s packaging.

appears to be working again (after today’s update) but note I’m running from the unstable repo

also, its crashing when closed

I just tried the latest updates from Factory and Digikam 1.2, still no joy. Switched back to 9.4 from repo again. :frowning:

I know this is an old post, but I just had the same problem in a fresh 11.3 install.

After reading on Digikam website I found the problem. The repos don’t update the dependencies automatically.

so check these dependencies and make sure they are manually updated.

libqt
kdelibs
libkipi
libkdcraw
libkexiv2
libgphoto2
liblcms
libtiff
libpng
libjasper :
libkdepimlibs (optional)

Then it would work.

Just updated digikam to 1.8.0 on Platform Version 4.6.00 (4.6.0) “release 395”
and found it could not find the database.

After fiddling a bit found the Type had to be changed from SQLite to MySQL.
Then all was back to normal.

-settings
–configure digikam
—Database File Path
----Type MySQL (select)

After a recent update to latest digikam (1.8.0-69.16_x86_64 from the KDE46 repo) and
kde4 4.6.1-390.1 (also from KDE46 repo) I have same issue - kio database startup errors when starting digikam from CLI.

Attempting to switch to MySQL did not work, but I had been using the default SQlite all along.

keellambert, were you using MySQL before the update?

Anyone else found a solution?

I have been running digikam 1.8 and kde4.6 from this repo for about a month now, frequent point updates but no issues until now.

digikam2-1.9.92 is in the playground repo Index of /repositories/KDE:/Unstable:/Playground/KDE_Release_46_openSUSE_11.4/x86_64 you could try it

Thanks for the digikam2 suggestion, I have been avoiding the temptation as I expect some one way database transitions.

As for my digikam1.8/kde4.6 situation, I saw a comment from a Ubuntu forum that a reboot solved the problem - and in fact rebooting my Suse 11.3 seems to have me back in business.

I also note that somehow in my latest round of updates kio_sys* files from the 11.4 distro got loaded into my system.
Simply backing them down to 11.3 did not solve this, but reboot after did.

My suggestions for folks with similar problems:
after update, reboot.
If still in trouble, search your install for files from 11.4 (?)

there is a digikam 1.90 (not digikam2) digiKam and Kipi-plugins 1.9.0 released… | digiKam - Photo Management Program, there is 1.95git in Index of /repositories/KDE:/Unstable:/Playground/KDE_Release_46_openSUSE_11.4/x86_64

Hi cmcgrath5035,

I havn’t looked at what I had immediately before the latest update of DigiKam.
But this is the first hic-cup updating in about 4 years.

The info on my current install gives :-

# rpm -q -a | grep sql
libsqlite3-0-3.7.5-2.1.x86_64
libmysqlclient_r16-5.1.53-6.1.x86_64
libreoffice-base-drivers-mysql-3.3.1.2-3.1.x86_64
libmysqld0-5.1.53-6.1.x86_64
mysql-community-server-client-5.1.53-6.1.x86_64
libqt4-sql-4.7.2+4.7.20110308-1.1.x86_64
libqt4-sql-sqlite-4.7.2+4.7.20110308-1.1.x86_64
libmysqlclient16-5.1.53-6.1.x86_64
mysql-community-server-5.1.53-6.1.x86_64
libsqlite3-0-32bit-3.7.5-2.1.x86_64
libqt4-sql-mysql-4.7.2+4.7.20110308-1.1.x86_64
# 

Hope this helps.

Addendum:

After the updates in oss today, Digikam updated to 1.8.0-69.5
Again it failed to start due to database error.
This time it was necessary to select ‘Internal Server’ in the page indicated below.

-settings
–configure digikam
—Database File Path
----Type MySQL (select)
-----Internal Server (needs to be checked)

The Check DB Connection then gave a positive response.

Note: The above change is not stored so needs to be repeated on
each subsequent start of Digikam.

Please don’t be offended by this, but please check that you have the file extensions (.jpg or whatever they are). Sometimes when batch renaming files in KDE Konq one can forget to add the file extension. Dolphin and Konq will still view the files as pictures without the extensions but Digikam will not display them at all. Even after a thumbnail rebuild or scan etc.

Hi,

For me its now solved. Its been fixed before I could think of raising a bug
report.

Digikam in now back to normal with version 1.8.0-69.5 from KDE:Release:46 /
openSUSE_11.4 dated 2011/Mar/05, in that it starts ok with Type: SQLite selected and
pictures automatically load from the selected local directories.

Digikam version 1.8.0-69.4 from KDE:Release:46 / openSUSE_11.4 dated 2011/Feb/28
would only load the database if Type: MySQL was selected and then only for the current
session.

Regards,
Michael

On 03/10/2011 10:36 PM, allianux wrote:

> Dolphin and Konq will still view the files as pictures without the
> extensions but Digikam will not display them at all.

that is not cool! and, imo is so MS-like it seems it ought to be a
brought up as a bug.


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11