DigiKam not starting after update

I updated my computer through Yast and now DigiKam crashes just after the splash screen.
When starting it in a terminal I get this

Fontconfig warning: "/etc/fonts/conf.d/56-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
"/org/freedesktop/UDisks2/drives/WDC_WD7500BPKT_00PK4T0_WD_WX31C62M7758" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/WDC_WD7500BPKT_00PK4T0_WD_WX31C62M7758" : property "Device" does not exist 
KCrash: Application 'digikam' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit

[1]+  Stopped                 digikam
sarge@linux-sarge:~> QSocketNotifier: Invalid socket 14 and type 'Read', disabling...

I have uninstalled and reinstalled DigiKam but that changed nothing, I tried deleting the config files - no change.
showFoto was installed with DigiKam and it looks to be working.

I’m using OpenSuse 12.3 64bit
KDE 4.10.2 release 1

Please see:https://forums.opensuse.org/english/get-technical-help-here/applications/486274-cant-load-digikam-photo-editor-after-upgrading-gnome-3-8-1-a.html

Well, I tried the test repo, rebooted but I got the same result.
Just after that a notification popped up with updates (including DigiKam)
After the updates, all is working :slight_smile:
Thanks for the help.

But you might want to remove that test repo again now.
Since it is for testing the updates before they get released as online update, there can be problems… (it’s there to catch those problems before the updates get released)

Thanks for that, I totally forgot to remove it.

I just installed 12.3 64bit and running KDE. DigiKam crashes when I try to launch it. I was able to go through the DigiKam setup (directories for pics, etc), and basically just took defaults. After that, it just crashes on trying to launch. DigiKam worked fine on 12.1 with exactly the same hardware. Is there a known problem, or should I go through the bug process?? Is there some way to recover and go through setup again??

Not sure if this should be an independent thread - don’t want to hijack this one, but it may be the same problem…

Regards – Roger

Have you tried to install it from the update test repo? (see https://forums.opensuse.org/english/get-technical-help-here/applications/486274-cant-load-digikam-photo-editor-after-upgrading-gnome-3-8-1-a.html)

What error message do you get when you run digikam from a konsole?

Thanks - sounds like DigiKam on 12.3 is down hard until next week (aside from test version). Sounds pathetic, but I have never had occasion to initiate a program from console. If I get a few minutes I will figure out what it takes and give it a try…

Regards – Roger

So you haven’t tried the test version yet. But I think, it will work for you…

Just run Konsole (you find it in the “Favorites” tab of the KDE startmenu) and type in the following:

sudo zypper ar http://download.opensuse.org/update/12.3-test/ testupdate
sudo zypper in -f digikam-3.1.0
sudo zypper rr testupdate

You will be asked for your root password (the same as your user’s password on a default install) after the first line.
After the second line you could be asked for conflict resolution. Just select the option which say “upgrade”. If in doubt ask! :wink:

After that, digikam should work fine for you…

Tried that and DigiKam is up and running. For some reason my new 12.3 install is not detecting USB devices (hotplug at least), so I can’t see if it works until I figure the USB issue out…

Thanks – Roger

Looks like USB connect is fine and DigiKam works fine. Need to locate and install the toolbar icon that shows usb connected devices…

USB is fine and DigiKam works fine as well. I just need to find and install the toolbar icon that provides USB device attachment notification…

Regards – Roger

And, did you find it?

If not, try to do the following:

  • right-click on the up-arrow on the right side of the system tray (the one which shows the hidden symbols)
  • select “System Tray Settings” from the context menu
  • check the checkbox for “Device Notifier”