digiKam 5.1.0 - first impressions

Have installed digiKam 5.1.0-148.1 from the Leap 42.1 openSUSE BuildService - KDE:Extra repository.

  • Deleted the default (Leap 42.1 update repository) 4.14.0 version and all it’s components before the “update”.
  • Deleted the ‘.kde4’ configuration and settings before the “first start” of the KF5 version.

Simply went through the start-up “Wizard” – pointed the thing at my digikam4.db (didn’t migrate the database – 10 years of digital photography) – and, it started.
(Giles has noted in a digiKam bug report that: “The update from a 4.x to a 5.x do not require a migration”.)
[HR][/HR]JPEG on screen picture quality (Adobe RGB colour space): WOW!! – definitely better than the KDE4 version.
(My JPEG pictures are generated from Sigma SD14 RAW files by means of the Sigma Photo Pro application running either on Windows 8.1 or 10.)

digiKam GUI “tools feel”: responsive, no mouse “drag”, no misbehaviour.
digiKam GUI “look”: needed to switch to “Breeze” and icons with “Breeze Dark”. (I’m an unashamed Oxygen fan but, find that sometimes it pays to “move with the times”.)

General photographic (first) impression: the previous digiKam versions were very good in terms of things photographers need to work with their pictures – IMHO digiKam version 5 has raised the bar (once again) with a number of small improvements which were made with the port from Qt4 to Qt5.
[HR][/HR]Yes, yes, as noted in another topic in this forum, a geolocation plugin is missing from the current Leap 42.1 KDE:Extras build but, given the early days with this digiKam version, IMHO one can live with this oversight.

Thanks for that.

I am another heavy-duty digiKam user, so I appreciate your input. Thanks.:slight_smile:

Update: with the patch introduced late last week to the KDE:Extra repository. the Geo-Location feature is now working as expected.

Does reverse geocoding work on your system?

Taking a picture with the coordinates 12° 35’ 51,4"E, 54° 26’ 16,5"N, and then right-clicking on thumbnail in the Geolocation tab and choosing “Address details” gives the result in a pop-up window of:

Am Eichberg, Wieck a. Darß, Darß/Fischland, Landkreis Vorpommern-Rügen, Mecklenburg-Vorpommern, 18375, Deutschland

I use the Marble maps – the above result seems to be independent of “Atlas” or “Open Street Map” and also independent of the map’s projection.

Sorry, my previous comment was related to the Marble Map.

At a first glance: no, it doesn’t: selecting a photo and then opening the Geolocation plugin from the Image menu and, using the reverse geolocation tab and executing with the option with “write to XMP”, doesn’t seem to do anything.

 > rpm -q --changelog digikam | head -20
* Mi Aug 10 2016 wbauer@tmo.at
- Add find_libastro-qt5.patch to fix build of geolocation support
  in Leap 42.1

* Mi Aug 10 2016 fabian@ritter-vogt.de
- Update to Digikam v5.1.0: https://www.digikam.org/node/756
  * many bugfixes
  * supports new RAW cameras
- Add build-32bits.patch to fix build on 32-bit x86

* Fr Jul 15 2016 wbauer@tmo.at
- Enable mediaplayer (Qt5Multimedia support)

* Mi Jul 13 2016 tittiatcoke@gmail.com
- Drop unused build dependency on sqlite2
- Obsolete the kipi-plugins5 package

* So Jul 10 2016 nico.kruber@gmail.com
- raise dependency on libkipi version


The reverse geocoding needs one of the digiKam internal tags to be set-up with things like {Land}, {State}, {State district}, {Province}, and so on – “remove all address elements” unfortunately currently does exactly the opposite [unless only the current German translation is exactly the opposite of what it really does . . . ].
Provided that the internal tag has keywords assigned to it, pressing the “apply reverse geocoding” and then “Apply” adds the keyword values/strings to the picture.
For example, the coordinates “54.4472256073,12.5827141217,0” apply the keywords: “Kirchenort, Prerow, Fischland, Darß, Mecklenburg-Vorpommern, Deutschland”.
[HR][/HR]We used to quip: “That’s to confuse the Russians.” – (With respect to part of the scheduler code in RSX11-M – DEC 16-bit operating system.)
Nowadays, there’s translations “to confuse the Germans” . . . :wink:

I am finding digikam v5 pretty good except that the Print Images and Print Assistant dont work correctly. Print Assistant should open with a whole bunch of papaer sizes plus custom in the window from the XML templates but it only shows Unsupported paper size and the Custom, also you cannot select all valid paper types some work and some dont and it stays oon the start up A$. Also landscape and portrait dont stick and dont change. Print Images has similar issues for me with paper sizes and landscape/portrait. I’d appreciate it if anyone here who can tests this and lets me know if they have any problems. My printer works fine on every other program I use it with so I dont believe it is the driver.


This seems to be the same behavior that I’m getting. Same result with and without the tick in XMP box, nothing gets written to the database.

I have my images on a read-only volume, I “only” use Digikam to keep a database of them. So before, when this worked, I’d get an error about not being able to write to the image file. Just ignored it, exited geolocation plugin, and the tags were in the database. Now I’ve also tested using images on read-write volume, no tags are written anywhere.

How does one assign keywords to an internal tag? I find nothing related to that in Digikam. Looking into the database I can find Tags like “Places” and its’ children “Finland”, “Uusimaa”, “Helsinki” etc. There is also table TagProperties that lists a few Tags with Property “internalTag”, the id for “Places” is not among those. I can find no keywords. So is this something that could be fixed by messing with the database or does it need to be fixed in the source code?

Other problems I’ve noticed with Digikam 5.1.0 (and 5.0.0). Startup takes a long time, seems to get stuck at “Loading KIPI plugins” even though I have none enabled (but I can live with this). Creating a new tag is SLOW (this is a serious). Map selection icon is not a globe like it used to be, but a folder (yep, not a real problem). Haven’t noticed other problems, but I do not use all the features. Nevertheless, even with these problems, I still use it :slight_smile:

Within the Geolocation plugin (Image menu), using the reverse geolocation tab, there’s a box in the middle with the digiKam internal tags.
Select at least one of the pictures listed in the bottom box.
Right-click an internal tag and either choose a single tag or the upper choice: “Set all address tags”.
Then, click the “apply reverse geolocation” button followed by click the “Apply” button.

Forgot from that list, Digikam sometimes crashes on exit. And says it can’t send a bug report due to some missing email address. But I can live with that too.

Never thought to right-click there. Seems to work. Thank you kindly!

Sorry, I now have an English language version running: the upper choice is “Add all address elements”.
To remove tags, it seems that the only way is to first run a batch job to remove the IPTC and XMP information.

Two things:

  1. digiKam5 doesn’t like changes of the user’s language preferences: if I change the user’s language from German to British English, digiKam5 crashes on starting. (Initialising a new database with a British English user doesn’t cause any problems or issues.)
  2. Did anyone else notice that the digiKam team have moved the Trash can? – It’s now private to digiKam and located within the Albums (it set up Trash cans per Album on my normal migrated collection).