Digest verification failed for file 'nvidia-gfxG05-kmp-default-470.103.01_k5.3.18_57-lp153.52.1.x86_

On running “zypper update” today I get this error message:

Retrieving package nvidia-gfxG05-kmp-default-470.103.01_k5.3.18_57-lp153.52.1.x86_64                                                                           (302/308),  24.1 MiB ( 90.9 MiB unpacked) 
Retrieving: nvidia-gfxG05-kmp-default-470.103.01_k5.3.18_57-lp153.52.1.x86_64.rpm ....................................................................................................[done (8.5 MiB/s)] 

Warning: Digest verification failed for file 'nvidia-gfxG05-kmp-default-470.103.01_k5.3.18_57-lp153.52.1.x86_64.rpm' 
[/var/tmp/AP_0xMvLQsl/x86_64/nvidia-gfxG05-kmp-default-470.103.01_k5.3.18_57-lp153.52.1.x86_64.rpm] 

  expected 00cba8b88e696efcfeabd06c833e02626fbcc6c5d5ada106a7ef53e292ba95c7 
  but got  9077b6ab6025e0db48594ee4481d1fb171edfdf661905699aefe3321430073bc 

Accepting packages with wrong checksums can lead to a corrupted system and in extreme cases even to a system compromise.

However if you made certain that the file with checksum '9077..' is secure, correct 
and should be used within this operation, enter the first 4 characters of the checksum 
to unblock using this file on your own risk. Empty input will discard the file. 

**Unblock or discard? [9077/...? shows all options] (discard): **

After zypper clean / zypper refresh didn’t help, I downloaded rpm and filelist.xml manually from the repo and verified (using sha256sum) that those checksums indeed don’t match.

Anybody seeing the same error? Anybody tried the “unblock” option? I know I’d probably be able to revert a bad update, but I absolutely need this PC to work tomorrow…

I have the same error on my Leap 15.3. I refused to install the updated RPMs.

It’s fixed!

Thank you, unknown fixer of checksums, whoever you are :slight_smile:

This is the nightmare I’m having atm. My 2nd generation motherboard died and I replaced it with more ram, i5 instead of i3 on a 4th generation board. My old mother board could have booted with efi but I carried on with legacy boot. The new mother board only booted my drive and existing system in ide mode not ahci mode, so I first tried converting to efi boot mode and because the latest kicad didn’t build for Leap:15.3 I decided to upgrade to Leap:15.4 release candidate.

Cut a long story short I first installed the dvd on a fast micro sd card and on installing I had a host of digest failure messages, tried a sandisk stick and had the same problem. Meanwhile I had formatted my root partition so after these failures, the installation system crashed every time .
I eventually, after chrooting from the installation system and using zypper dup with updated repositories and boot installed system from the installation system I had a system which worked but kde kept on crashing and freezing.
So now I decide to fresh install tumbleweed and guess what I get Digest verification failures again and they appear to be the same packages that the 15.4 installation failed on.

Please can anyone tell me what could be causing the Digest failure in certain packages.

I’m going to try plugging the hard drive into my laptop and see if I can install from there.

You may use builtin Intel GPU in laptop.
You may install Nvidia drivers “the hard way”, downloaded from Nvidia’s website.

Hi
Faulty RAM…