difficulty with portable harddrive


I’m a recent convert from windows machines to linux. From the first distro I tried I was blown away by how great linux is. But opensuse, while it has taken me a little bit longer to figure a few things out, has by far the best. It even allows me to configure my touchpad so it doesn’t drive me insane.

On to my actual problem. the portable harddrive placed all my files on to when switching from windows mounts but shows up empty.
I know the files are there because they show up when i plug the harddrive into my ps3.

I put the all the files i wanted to save from windows into a folder called portableharddrive (i think) and put that folder on to the portable harddrive.

if i do a directory search by running the drive in terminal this is what i get

enrico@linux-x282:/media/EE2C-16EB> dir -l
ls: cannot access $recycle.bin: Input/output error
total 32
drwx------ 13 enrico users 32768 2010-01-09 03:08 port hard drive
d??? ? ? ? ? ? $recycle.bin

I then tried to switch to the directory port hard drive but this is what happened.

enrico@linux-x282:/media/EE2C-16EB> cd port hard drive
bash: cd: port: No such file or directory.

Can anyone help me find my files or do i have to wait untill my girlfriend gets her computer back?

If your portable drive is using ntfs, install ntfs-config and run it. This utility will help you to mount external drive with ntfs without any problem.

ill give that a try but Im pretty sure the file system on that harddrive is fat32

nope didn’t work.

also the ps3 only reads external drives that are fat32 so i know for sure the drive is fat32

cd port\ hard\ drive

or just use tab completion

cd port<TAB>

and it will fill out the rest of the name.

Or you could use a file browser like dolphin on the FAT32 filesystem once mounted.


so since Im using Gnome I know if dolphin would work, so i opened it in terminal and typed in

cd port\ hard\ drive

as ken_yap suggested.

everything was there.

But then when i clicked on the actuall drive with the file manager suddenly everything was there too!!! when befor those files were invisible in nautilaus.

Don’t know how or why, but Kens instructions at least temporarily fixed it for me

thank you.