Difficulty Installing ATI Video Card


System Specs:
CPU 2X Intel(R) Pentium(R) 4 CPU 3.20 GHz
MEM 3611MB
786E1 v0.10
Hewlett-Packard (Yes it may take a minute to find this board, it’s been a continual pain for me)

OS ~ Currently None ~ Using PartedMagic (HIRENS 14.1) to do a complete clean before reinstalling OS.
Would like to use openSUSE 12.3 KDE 32bit

I have a Diamond Radeon HD 6670 2Gb Video Card. When I put the video card on the board and boot up I am unable to get to even the install screen for openSUSE 12.3. As soon as it goes to the screen where the loading bar at the bottom of the window would show the screen on my monitor turns to ‘static’ with the monitor plugged into the card, and a black screen if plugged into the board video out.
I have made a bootable USB with the install for openSUSE 12.3 (both Gnome and KDE) and am booting from it. I’ve had it fully installed, without the ATI video card, and tried to install the proprietary driver but it stops the install when it can not find the respective hardware. The static problem I still get if I install openSUSE without the video card and then shut down plug in the video card and try to restart it. So I’m stuck in something of a catch 22. I have the proprietary on the USB as well but when I try to install and choose to use drivers from other sources: USB ~ proprietary drivers :it does not install the catalyst proprietary I’m assuming because it does not see the hardware to need it and so I’m still stuck without being able to get the video card even working enough to be able to have it on the board.

So before I reinstall the OS I’m presenting this problem to everyone in the hopes maybe someone has already encountered it with this board/ati video card and has a solution. Simply put I’m asking for help starting from scratch with clean system to start on. I’ll even reset the bios again if someone thinks that would help.

Oh and any responses please do so as if I was effectively completely ignorant in regards to computers. I’m not but that way in case I don’t think to ask about something hopefully you’ll already have covered it. I am new to linux, so it’s really not that far off in this situation.


(I noticed I’d posted this in the wrong thread, so I’m moving it over here to hardware.)

I don’t think this is helpful at this point but just in case:


00:00.0 Host bridge: Intel Corporation 82Q963/Q965 Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
00:03.0 Communication controller: Intel Corporation 82Q963/Q965 HECI Controller (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82566DM Gigabit Network Connection (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HO (ICH8DO) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE Controller (rev 02)

The correct way to do this is to press the triangular icon at the bottom of each post and ask the moderator to move the thread

Ah huge thanks! Used that to report I’d already copy and pasted over but to ask them to remove it from over in Multimedia.
Will remember that for the future.


We have already noticed this (though vazhavandan shows the correct way). The other one will be deleted.

you are welcome

Just in case it would help:

product: HP Compaq dc7700 Small Form Factor
vendor: Hewlett-Packard
serial: 2UA72611B0
width: 32 bits
SMBIOS version 2.4,
DMI version 2.4,
SMP specification v1.4,
Symmetric Multi-Processing
boot: normal
chassis: low-profile
cpus: 1
uuid: 33DC114F-CC26-DC11-BBDA-BBDE67CD0019

Okay, so not seeing responses to the actual problem I decided to go back to trying to tackle it myself and have had some luck.

I’d not been able to add Index of /mirror/amd-fglrx/openSUSE_12.3
kept getting a backend message
so I went and decided to try to click install at the link myself, had tried this a few times before but what the heck, let’s try it again… this time it took and installed

obviously without the video card on the board

so after installing, I shut down, put the card onto the board, then started back up

as of right now it’s working, and I was just able to add the repository… why now and not before I don’t know but oh well it took this time