Different archives are made by the same _service file (with bzr) in my local computer and in OBS


I wrote the _service file to get the freshest sources from bazaar. In my local computer I run osc build --ccache openSUSE_12.1 x86_64 or osc service run and I get _service:recompress:tar_scm:python-itmages-service-0.38.tar.bz2 and it is OK. But when I commit it into OBS service made archive with filename _service:recompress:tar_scm:python-itmages-service-38.tar.bz2 (without “0.”) and it is wrong.

_service — https://build.opensuse.org/package/view_file?file=_service&package=itmages-service&project=home%3ADarkSS&rev=86acedbaeafdd2498e3173daa521e489

log from OBS — https://build.opensuse.org/package/live_build_log?arch=i586&package=itmages-service&project=home%3ADarkSS&repository=openSUSE_12.1

my local log — #183764 • KDE Pastebin](http://paste.kde.org/183764/)

Could anybody help my please?

Best regards,
Dmitriy DarkneSS Perlow / Linux x64

It works into https://build.opensuse.org/package/show?package=itmages-dolphin-extension&project=home%3ADarkSS
But it doesn’t work into https://build.opensuse.org/package/show?package=itmages-plasma-applet&project=home%3ADarkSS

In order to make rpm I added correct tarball manually.
You could check content of _service files with filenames of archives.

When I type <param name=“versionprefix”>0</param> OBS (but not my local computer) skips it. I tried “0” ‘0’ 0. 00 0 ![CDATA[0]] but OBS reads it as it is.
How may I tell OBS that 0 isn’t nothing?

OK. You mustn’t use <param name=“versionprefix”>0</param>. You should use <param name=“version”>0.blablabla</param> instead of it.