Did AMD break atiupgrade ?

I am running SUSE 11.4 x86_64/KDE 4.7.2

I tried running script atiupgrade, it returned message that I had the latest already installed, 11-9.

Perhaps there is no 11-10 (yet)?

Out of curiosity, I went to the AMD webinterface to see what it said was available.
It has a new GUI, which does not seem to work. I entered all my information, but Step 5 Display Information does nothing.
I tried same on WinXP/IE9, get an error “requires Flash 11”.
I am running flash ver 11.0.1 here in SuSE machine.
So that seems to be a bleeding edge Flash issue, I’ll deal with that.

However, I then tried to browse to http://www2.ati.com/drivers/linux, which atiupgrade has as


I get a file not found error.

I recall in the past being able to browse that directory.

Did AMD/ATI move the base directory?

Is ther a Catalyst 11-10 yet?


atiupgrade doesn’t use this URL to determine if a new driver is available but the one specified in atiDownloadUrl: [noparse] http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx[/noparse]](http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx). This one is browsable. Then it follows the download link found on this page, currently: http://www2.ati.com/drivers/linux/ati-driver-installer-11-9-x86.x86_64.run. The directory doesn’t need to be browsable for a page to be viewable or a file downloadable.



installed ati-driver-installer-11-10-x86.x86_64.run manually from

No problems installing and running on the following OS

ATI Radeon HD 3200 Graphics
Linux 3.1.0-3-desktop x86_64
KDE 4.7.3 (4.7.3) “release 10”

It was broken indeed. Replacing the line




seems to have fixed the issue. A patched version is available here: Upgrading ATI driver with atiupgrade - Page 9. The package is still building in OBS (waiting actually).