Did a clean install and 12.1 STILL will only boot in Failsafe System V

After the “upgrade” trashed my 11.4 system, I put in a new drive and did a clean install. No matter what I do, following many other hints and tips, it will only boot in Failsafe mode - preferably with System V.

I’ve been running Suse since 9.3, but this is getting a bit old.

If I try to do a desktop start, I get only the command prompt. Startx doesn’t work.

If I go failsafe, it locks up after about 15 minutes, just doing normal things, Firefox, Thunderbird mail, etc. And no changes to the panel last till the next boot.

Do I need to start over again?

You will not get a useful answer until you divulge in detail what your hardware is and exactly what you did to install 12.1.

On 11/21/2011 08:06 AM, eng-int wrote:
>
> You will not get a useful answer until you divulge in detail what your
> hardware is and exactly what you did to install 12.1.

and, did you do this prior to beginning the instal:
http://tinyurl.com/3qde66h


DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software
dump Flash: http://www.bbc.co.uk/news/technology-15797399

OK…

I have a 6750 Dual core, 4 GB memory, and brand new 500 GB HD, dvd, etc, nvidia 9800GT graphics card,
I downloaded and installed the DVD install to the new drive, all on one partition. The check number was correct.

At first, the boot put me into level 3 (command prompt) and logged in as root.
From there, tried startx. Failure. I’m not all that competent to do much more there than look around.
Reboot to Failsafe. Lockup and frozen before the desktop showed up.
Reboot to failsafe again, trying System V, and I get a desktop. Works for a while, then freezes.
Reboot to failsafe again, trying Systemd, doesn’t make it to the desktop.
Rinse, repeat over and over.

I guess I’ll try another install from scratch and see what happens, unless someone has a better idea.

and thanks for any help.

Yes I did check the media. See my reply here for other detail that I hope will help.

If the media check is OK, reinstalling won’t help much. My guess is that the nouveau driver is not playing nicely. Boot into runlevel 3, login with username and password and do:


su -c yast
(enter rootpassword)


Now go Software - Software repositories - Add - Repo’s maintained by the community
Check the NVIDIA repo, confirm all, import key when asked for
When done, start Software Manager, if all is well the NVIDIA driver should be selected for install. Accept, the installer will make the necessary changes re. settings. Reboot and you should have a nice running desktop

I downloaded and installed the DVD install to the new drive, all on one partition.

What type of installation did you choose (KDE, Gnome, minimum X11, server, etc.)?

Did the install complete? Did you choose auto (passwordless) login? I am trying to determine whether you are actually in level 3 (networking, and user login possible) or if the installation failled and you are in run level 1 (only root login possible).

You would have to have installed a graphical environment to get to use startx from run level 3.
Onlly use * init=systemvd* otherwise the boot messages are cleared from the console (tty1) screen.

KDE installation. Yes, the installation completed. I did choose a password. When I login on the command prompt, I can login as myself or root successfully.
I will try the init… command and see what happens.