Dictionary Applet suddenly no longer finds dictionary -- can't find solution in this forum

I am using OpenSuSE 12.3 with KDE 4.10.5 “release 1.”

I have had the dictionary applet on a bar at the top of my screen working perfectly for months. Now today I find when I click on the dictionary icon and type a word to look-up in the “Enter word to define here” box, nothing happens. I get no results.

I’m guessing that the dictionary applet is looking for a dictionary but can’t find one. For the life of me I can’t figure out what has changed or where to find a dictionary for the applet.

I did do an update last night when SuSE notified me there were new items available.

I have searched the lists here and only found reference to qstardict-kde. But that did not help. It apparently is for a different dictionary and isn’t working for me.

I have tried removing and re-inserting the dictionary applet. Did not help. I also tried rebooting the pooter. Did not help.

Can anyone help me find the missing dictionary and then tell me how to connect it to the dictionary applet?

Many thanks. :shake:

The dictionary uses pan.alephnull.com as the backend for queries and that website seems to be down and no dictionary entries can be fetched.

So it’s not something I’m doing wrong nor did I clumsily destroy some file that the dictionary was looking for? Thank goodness I didn’t screw it up! rotfl!

Thanks for the reply. I’ll just keep trying the dictionary icon until it starts working again.


That website is back up this morning, but clicking on the dictionary icon (widget) brings back no results.

What next?


Works for me - have you tried removing the applet from the desktop and re-adding it?

Yes, I have tried removing and replacing the widget (it’s a widget, right? not an applet – my mistake in original thread title) on the bar at both top and bottom of the screen. I have also tried putting the dictionary on the desktop.

No results come back no matter where I put the dictionary.

Note: this dictionary is the one you get by right clicking on a bar, selecting “add widget,” and then selecting the Dictionary (NOT the

This used to bring back results. Now nothing.

Any ideas on where the dictionary actually resides within SuSE 12.3 and how I can tie it to the Dictionary icon on my top bar?


Yes sorry - of course it’s a widget.

I’m out of suggestions I’m afraid - perhaps someone else has insight on the matter? I can’t find any configuration or any other information about the widget that would allow debugging it somehow - I only happened to know where it fetched the data.


I added the following two files from YaST software management:


and now the widget works again. rotfl!