Dialogs appears very small in firefox

Since I have installed Leap 15, some dialogs appear very little in firefox

This is what it looked before
https://susepaste.org/33118804

And this is what it looks now
https://susepaste.org/35576879

I was using firefox from the OSS repo buth I have switched to the one in mozilla repo ( 65.0.1) but it continues the same.

May be some library?

regards

I have not seen that happen. However, perhaps it only happens at some sites and I haven’t used those sites.

It’s also hard to say, based only on those images, whether it is a firefox bug or a coding bug at the site where you are seeing the problem.

I’m using firefox and haven’t observed this behaviour. Any particular website(s)?

Can you install Chromium or SeaMonkey and render that login page with one of those browsers?
(I use SeaMonkey for all websites and for E-Mail, Chromium for 3d-accelerated Google Maps and Firefox for comparisons/testing etc.)

Maybe this way we can determine whether it is the browser’s fault or the website’s fault?

I have a mikrotik router and this is the login page with Firefox
https://susepaste.org/14902546
And with Opera (and it showed this way before with firefox)
https://susepaste.org/96958504

And this othe site, with firefox
https://susepaste.org/86421477And with opera
https://susepaste.org/33075834

By the way, this is happenning to me today with the front page of the forum
https://susepaste.org/12122210

Yes.
In seamonkey it appear like in firefox (bad)
https://susepaste.org/36727932
In Chromium it appears like in Opera (good)
https://susepaste.org/80082235

Maybe it is not just a firefox problem (at least it is firefox’s and seamonkey’s).
This happens also with firefox
https://susepaste.org/25794383
I can’t see anything in the downloads because it is so small

I have similar problems with LibreOffice when saving a file
https://susepaste.org/74392640
Dialog is very small. In this case I can expand it although every time I save something I have to expand it.

I vaguely remember having Firefox- and Seamonkey- specific problems like that while using a broken GTK2 theme way back.
Nowadays, both browsers rely on GTK3 for rendering UI elements, even within a website (prime suspects: textfields, radiobuttons, checkboxes and your standard scrollbar).

On the other hand, Chrome/Chromium and Opera seem to roll their own UI, not sure.

Try using another Gtk3/Gnome default theme (log out and in again to be on the safe side), and if you are so inclined, experiment with the GNOMErunner add-on (I use the add-on to make my SeaMonkey scrollbars to look like my standard KDE/Plasma5 scrollbars).

Right. Both Firefox and Seamonkey use GTK3 … LibreOffice too, true?
Changing Settings-Application Style-Gnome Application Style (GTK) from Breeze to Adwaita solved the problem with Firefox and Seamonkey, It did not change the size of LibreOffice dialogues… I will continue searching.
Adwaita theme is ugly… looks like old Netscape but if it works it works :slight_smile:

It seems it not only depends on the theme but on the font.
With adwaita and adobe courier it looks ok, but with adwaita and times new roman it looks bad.
Maybe it is neccesary a monospaced font?

Some pages do not even work with other theme and font, for instance this kind of pages

https://www.pololu.com/product/4209

This is the aspect in firefox

This is the aspect in opera

Both of the images you posted seem similar to me. If it’s just a sizing issue in firefox, just adjust with <CTRL> <+> or <CTRL> <->

I’m not an Opera user, but in an effort to understand/assist, I did install it and then viewed the page directly in both. The firefox default view was smaller initially, but it was easy enough to make the same size by zooming in to match.

The problem is not the size but the size of the text boxes.
I copy other snapshots here. Pay attention to the text box right of “quantity” I have typed 12345 in the three cases

Opera

Firefox

Firefox zoomed (cntrl+) several times

The problem is that the text box is so tiny I can even see the text I type in.
When I zoom the window everything is zoomed except the text boxes.

Strange. I’m not getting the same issue (text box size) here with firefox.

The problem is related to the input element in the html code


<label for='product_quantity'>Quantity:</label>
<input id='product_quantity' name='product[quantity]' size='2' type='text' value='1'>

I’m making some test.
I have created a file named test.html


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<body>
<p>
<label for='product_quantity'>Quantity:</label>
<input id='product_quantity' name='product[quantity]' size='50' type='text' value='9999999999999999999999999'>
<br>
</p>
</body>
</html>

This is the aspect of the page displayed in Opera

This is the aspect of the page displayed in firefox

So the problem seems to be that firefox ignores the size of the dialog (and Seamonkey too)

That doesn’t explain why it misbehaves in your firefox environment, but not in mine. The test.html code displays fine for me (similar to the Opera output).

Yes, it displays fine here, too. This is with firefox 60.5.1esr.

It’s the same I have.
I have other computer with Opensuse 42.3 and the same firefox version and it display the page fine.

What were you using before 15.0? Is 15.0 using an older filesystem for /home/ or /usr/local/ from whatever came before, an old user and old settings, an old 12.1 installation upgraded to 12.2, then 12.3, 13.1, 13.2, 42.x, to 15.0?

Which DE or WM are you using? If using Gnome, Plasma, LXQt, XFCE, Enlightenment, Mate, or Cinnamon, what if you use a different session type to try Firefox? IceWM should already be among your login greeter choices, simple and light weight to test with.

What extensions do you have enabled in Firefox?

How old is your Firefox profile? Does it have a chrome directory in it? If it does, shut Firefox down, rename the chrome directory something else, then try Firefox. chrome is an optional profile directory, so might not exist if the profile isn’t very old. To me this seems to be a …/profiledir/chrome/userChrome.css problem, which could have been caused by an extension, except that it affects your SeaMonkey too. Thus I don’t think this is the problem, but a local system or user data problem.

The styling of input boxes is by default controlled by your desktop theming. Many web pages override input box styles, but https://www.pololu.com/product/4209 isn’t one of them. Note that it is using a very old doctype and doesn’t validate: https://validator.w3.org/nu/?doc=https%3A%2F%2Fwww.pololu.com%2Fproduct%2F4209

You may find if you create a virgin login/user that the problem will not manifest in it. This smells like a user settings or system settings problem coming from something in /etc/gtk-3.0/ or ~/.config/gtk-3.0/ or /usr/local/etc/gtk-3.0/. Do any dialogs in Gimp or LibreOffice or some other GTK3 application besides SeaMonkey manifest the same problem?

I have installed OS 15.0 from scratch, but /home is a old /home partition.
How old is the firefox profile? … maybe 20 years … if it may be inherit from Netscape
I have tried from a newly created user and it displays the page well with firefox.
I don’t have a chrome directoy inside firefox profile

Dialog in LibreOffice don’t behave very well either. They display very small too for instance when saving a file… althoug the can be redimensioned.