Has anybody connected to the internet with dial-up? I posted a query on the “applications” forum about kppp, and deano-ferrari and others have made suggestions. The problem is not hardware; I can connect with 13.1 with the same system, using qinternet. I have installed qtwvdialer-wvdial and its dependencies. Both kppp and qtwvdialer start pppd, according to ksysguard but do not connect. I tried installing qinternet but there is no YAST module to configure a dial-up modem in 42.1. (SuSE user since 6.1)

Recall reading telco’s moving to drop dial-up services, they believing no longer worth maintaining.

BTW very aware this ignores those beyond reach of ADSL or wireless, yet still with working telephone lines.

At this stage I can only suggest that you submit a bug report describing the problem. Some debugging information will be required…

Open a terminal window and and monitor the system log using

sudo journalctl -f

Then (assuming you have already configured /etc/wvdial.conf), try to dial using ‘wvdial’ in another terminal (as root if required)


Capture the output from both terminal widows.

Compare against the working openSUSE 13.1 output. For this you can observe the system messages using

sudo tail -f /var/log/messages

If necessary, the pppd debug level can be invoked by including ‘debug’ in /etc/ppp/options, which pppd reads when started.

The relevant section of /etc/ppp/options is shown below. The ‘debug’ entry is commented by the ‘#’ character (so uncomment as necessary)

# Increase debugging level (same as -d). The debug output is written
# to syslog LOG_LOCAL2.

# Enable debugging code in the kernel-level PPP driver.  The argument n
# is a number which is the sum of the following values: 1 to enable
# general debug messages, 2 to request that the contents of received
# packets be printed, and 4 to request that the contents of transmitted
# packets be printed.
#kdebug n