DHT Disabled on Ktorrent

Why do people at openSUSE disable DHT on Ktorrent? In these days of Broad Band etc, it slows the whole thing down by a considerable measure!
Is there any way to reverse it, say by installing from Ktorrent from the source, rather than the SUSE package?

It isn’t disabled in Opensuse, it just isn’t enabled by default in ktorrent. I don’t think it has been enabled by default in any KDE distro I’ve used.

DHT is disabled in 11.0. It is a Novell thing I am sure. The work around is to get the version from Packman… Remember to take the Virtual package rather than just update the app. This creates a dependency that reminds you that you do not want the official hamstrung version.

chrazer, how do you go about doing that? I looked in the wiki, but found nothing about “virtual packages”. Could you enlighten me/us?

edit: nevermind, I just found it over here.

Using 11.2.
With original KTorrent experienced the same problem with DHT.
Following the recommendation in this thread, I switched to Packman, and it works now.
BTW, GUI looks completely different.