DHCP NIC Not Transmitting, Only Receiving

I am using my 13.2 laptop to try and solve a network problem which I suspect is related to DHCP.

I have set up the laptop network interface using Wicked to get its address using DHCP with wireless disabled.

I re-boot with lan cable disconnected so I can start Wireshark and have it running when I plug in cable.

I was hoping to see the DHCP handshaking process but no joy. The NIC receives much traffic from the lan but cannot transmit.

However if I re-start then all is well and the NIC gets an address but I am then too late to capture the DHCP process.

What Wicked setting should I use if I want the NIC to wake up when I plug in? I have tried all options but none seem to work so want to get it right before I go further.

Will I then see the DHCP process?

Grateful for any help here.

Haven’t thought about this for a long time, and a Google search doesn’t seem to return any hits for me… So…

  1. You can capture from another machine.
    Before you boot your machine, another machine running Wireshark with its NIC set in promiscuous mode would definitely work. You’ll have to figure out whether the NIC is set to promiscuous mode(captures all packets on the network regardless of source or destination). In the old, old days NICs were uniformly set to off, but I’ve noticed over the years that Linux has been enabling more commonly.

  2. It’s almost certainly possible to attach a serial console, but it’s not something I’ve done before.

  3. It may be possible to start tcpdump very early, eg to make it a requirement before networking starts. Tcpdump is an important app to know for capturing network data because unlike Wireshark it’s small, simple and “just works.” Then, you can use Wireshark or something similar to read and analyze the data dumps.

You may also see a relevant error in the journal. There used to be a separate log for network connections, I assume that’s all in the journal now.


Hi Tsu,many thanks for the suggestions. As you can tell from my posts I am trying to sort out a problem on my network and am uncovering plenty of issues. After posting I worked out I could use another machine on the same subnet. I think Wireshark puts nic into promiscuous mode. Not sure about tcpdump but it is mentioned in my references. I shall keep trying along your first suggestion and report back when I next get stuck.

I believe you need to enable nanny. This white paper (although for SLE) has description how to do it. https://www.suse.com/documentation/sles-12/pdfdoc/networking_with_wicked_in_suse_linux_enterprise_12_guide/networking_with_wicked_in_suse_linux_enterprise_12_guide.pdf

Took a look at your reference.
Looks like it would be a good setting if the journal service hasn’t started up soon enough although I’d be surprised if this were to be the case (I’m pretty sure all basic system services including starting the journal has to be started before networking starts although I might be wrong). I’d think that the nanny service would be very useful troubleshooting PXE booting.

But, I don’t see that it will necessarily capture what you want since I don’t know that a dhcp error is actually thrown so would be logged with some actionable info.