DHCP gives error when trying to start service


I have a opensuse 11.2 server
When I start I get the message “Error occurred while restarting the DHCP daemon.”

When I check the logs I find “socket: Address family not supported by protocol - make sure CONFIG_PACKET (Packet socket) and CONFIG_FILTER (Socket Filtering) are enabled in your kernel configuration!”

Where can I activate these or is this another fault?

Br Andreas

That sort of thing should not happen. Only thing I can think of is you updated the kernel and haven’t rebooted yet.

I did update the server before i tried to start the DHCP server there was a kernel update included there I belive…
But I have tried to restart the server since.

Where can I check if these configs that are mentioned are set correctly? I have tried to uninstall all that have anything to do with DHCP and then reinstall it no luck.

Br Andreas

There shouldn’t be any config needed for those capabilities, they are present in a normal kernel with working modules. Check that you really have rebooted the right kernel. uname -a should give a kernel release of

I uninstalled all DHCP and restared the server and reinstalled all DHCP related stuff then it suddely worked.
I´m not sure if it was the reinstall or the reboot that fixed the problem.

Thanks for trying!

BR Andreas

Probably the reboot. When a new kernel is installed, all the kernel modules are removed from the filesystem even though the kernel is still running, so any extra modules required cannot be loaded on demand, until the running kernel is changed also.

I’ve complained in the past about this somewhat reckless behaviour of SuSE kernel updates, not leaving at least one older kernel available, but I suppose if too many kernels are retained, then /boot could fill up.