Devices involved in wake from sleep / suspend to memory


I have openSUSE 11.4 KDE (upgraded to Tumbleweed but that’s not relevant here). The computer is a Dell Optiplex. My sleep (suspend to ram) and wake (restore from ram) work very well. The box can multiboot to windows 7 as well as to Linux.

In Linux, the restore process is triggered by pressing the power button on the front of the case. No other action will bring it awake.
In windows, the restore process is triggered by the power button but also by moving the mouse or touching the Escape key, spacebar etc.

Here’s the question: how do I get the computer to wake in Linux by activating a key (or mouse, whatever) instead of just the power button (which is under the desk and hard to get to)?

Interesting question John! I’ve always just accepted triggering the wake via the power button. Anyway, I found these which may assist enabling the keyboard and mouse triggers you desire:

Ubuntu: Resume From Suspend With Keyboard/Mouse | Bobby Baker

This thread may (or may not) be relevant to your situation.

I’m having the same difficulty in 11.4, trying to find a way to enable waking from S3 with mouse and keyboard. I’ve tried the links above (and several other forum threads and tutorials) but to no avail. I’ve set all the usb devices in /proc/acpi/wakeup to enabled, but none of them wake the PC from sleep.

Have you checked your BIOS configuration for any possibly relevant settings as well? I would do the same, but somebody has enabled a password on my inherited work laptop, preventing me from playing :frowning:

I do not thing bios configuration is causing my situation, as it works fine in windows for this PC. I suspect there’s something the links above took for granted as common knowledge which seems rather esoteric to me…

Ok. What output do you get from

cat /proc/acpi/wakeup

After “echo USB1 > /proc/acpi/wakeup” etc, the USB devices appear as follows

USB1 S3 *enabled
USB2 S3 *enabled
USB3 S3 *enabled
USB4 S3 *enabled
USB5 S3 *enabled
USB6 S3 *enabled
USB7 S3 *enabled

It goes away when I reboot though and when I tried the script linked above my system failed to boot to run level 5 until I deleted it. Even with these in place my system does not wake from sleep with any USB device.

Hmmm Wake on Lan is also not working.

Edit: Actually, Wake on Lan kinda works. After “echo GLAN > /proc/acpi/wakeup” I can at least connect with KVM but all I get is a black screen.

Even more curious, when I connect via KVM while the PC is asleep, the fans are still motionless and there is no activity. The PC does not fully wake via the KVM…

BUT, suddenly the local keyboard is able to wake it whether or not KVM is active.

The local mouse still does not wake the PC at all with or without KVM.

I was having the same problem, I also have a dual boot Win 7/openSuse setup.

I found this link Pyther’s Intraworld

Under the “Use keyboard to wake for standby”, I followed the steps, now pressing the space bar on my keyboard wakes the computer from standby:)