Device Notifier Options?

Hi,

Version 11.2 with KDE.

When I plug in a usb device, the device notifier pops up and tells me about it and when I click on the device I get a menu that gives three options; “Download photos with digiKam”, “Open with file manager” and “do nothing”.

How can I change these?

I never use digiKam, so I’d like rid of the option. Sometimes opening with file manager is what I want but often just mounting the device is what I want to do (“do nothing” doesn’t do that, it…err… does nothing).

Help appreciated.

I don’t share the annoyance, hence I know where to go, but not what to do on this subject. Go Systemsettings - Advanced - Device Actions. That’s where all this can be set, just cannot help you on how. There is a Help section about it.

Thanks for the pointer, Knurpht.

Unfortunately, the help page wasn’t really much help; it told me everything that was obvious anyway and said nothing of that which wasn’t.

Ho-hum.

The first problem was getting rid of the digiKam action - you can’t. At least not from the Device Actions options. I tried removing digiKam altogether and that worked. However, that removed showFoto - which I wanted.

After some googling I discerned that the actions were stored as .desktop files in /usr/share/kde4/apps/solid/actions. So I deleted it :slight_smile:

Now, a mount only option. The System settings were somewhat more use here. I created an action that usefully defaulted to all StorageVolumes but I’d no idea what command to put in it.

Noting that many other actions used a %f parameter I decided (as a first step) to pop up a kdialog to see what it was.

It turns out to be the path to the device files - something like “/media/disk”. It also appears to mount the device in the process of displaying this information.

At my low level of linux knowledge, this would seem to make sense, since the files don’t have a location in the file system until the device is mounted??

So I’ve sort of achieved what I wanted.

It would be nice to have a command to do the mount without the dialog though…

Olmy wrote:
> It would be nice to have a command to do the mount without the dialog
> though…

well, you don’t even have to do that, because by the time you first
see the device notifier pop up the USB device is mounted…

try it yourself:

  • with the USB not inserted: open your favorite file manager
  • navigate to /media, and look inside that folder
  • insert the USB device
  • soon you will see your USB device appear (you may have to refresh
    the file manager’s display, depending on what KDE4’s Dolphin can do)

alternatively, just click on My Computer on the desktop and spy the
Disk Information section, and plug in the USB device and watch it appear…

it is automounted by HAL (Hardware Abstraction Layer) which then
triggers the device notifier (and makes the device icon appear in file
managers/My Computer)…

so, if you just want it mounted then in the device notifier, when it
pops up:

  • click Do Nothing then Ok
  • or just hit the “Cancel” button…

btw: i learned last week that before unplugging the device we are
“supposed to” right click on the device (in a file manager or My
Computer) and then select “Safely Remove” and wait for the device’s
icon to disappear…[something i’d never done, with any ill
effects…mostly, i guess, because i knew to make sure the device was
not in use, and THEN pull it out.]


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Hi DenverD,

My system does not behave as you describe. When I plug in, it appears in the ‘places’ panel in dolphin and in my computer (without usage information) but not until I take some other action (open in file manager or my display popup) does it appear under /media and the full info appear under my computer.

Until then, also, the various ‘safe remove’ options do not appear…

Olmy wrote:
> Hi DenverD,
>
> My system does not behave as you describe.

as far as i can tell: you have a faulty or damaged install…did you
do this http://tinyurl.com/yajm2aq before install? if not, do it
now…if the disk as any error you must see here:
http://en.opensuse.org/Download_Help
http://tinyurl.com/yhf65pv
http://tinyurl.com/ycly3eg

if there are no errors in your install media then your system did not
install correctly (did you have any errors) or is somehow damaged by
updates or other user actions and must be repaired, or replaced…


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Looks like it changed for 11.2…

Automounting USB flash or external drives - openSUSE Forums

Olmy wrote:
> Looks like it changed for 11.2…

sorry! i missed that (or learned and then forgot it)…

and, now i have another good reason to stick with 10.3, which is
superior in many ways…for me.


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

No probs.

Anyway, since accessing ‘%f’ seems to mount, I have now set my command to ‘echo %f >/dev/null’ - which seems to do the trick…

Olmy wrote:
> Anyway, since accessing ‘%f’ seems to mount, I have now set my command
> to ‘echo %f >/dev/null’ - which seems to do the trick…

good solution!


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio