device-mapper: remove ioctl on system-root failed

I get: “device-mapper: remove ioctl on system-root failed: Device or resource busy” and “device-mapper: remove ioctl on cr_scsi_hard_drive-name: Device or resource busy” during shutdown. It happens in excess of 80% of the time, but not every time. Apparently something in my root partition is not being released quickly enough during shutdown and device-mapper is complaining about it. I might note that I do not get errors concerning “system-home” which is a different partition on the same drive.
The errors apparently cause no damage that I can tell and only delays shutdown a second or two. It’s just annoying. There are many theories available, but nothing definitive that I found. Some blame dracut and say that a delay is needed during the shutdown sequence. Some say to disable plymouth. Many say that SSDs are affected while SATA drives are not. My machine uses an very quick M.2 drive, so the theory about SSDs may be correct.

Getting the same error messages in Leap 42.3 since about one week, after regular update. According to this post the problem must have been solved in 2016…

Any clue about how to solve it?

There is no way to unconfigure LV used for system root while system is using it and you cannot stop using root while any program (like PID1) is running. You would need to jump back into RAM disk and do it from there (basically reversing what initrd does on boot). Technical prerequisites for doing it exist but apparently so far nobody was interested (motivated) enough to create generic implementation.

At the time you see this message all filesystems must be read-only so it is more or less cosmetic.

There’s actually an open bug report on this: Bug 1080485.

Yes, I see the problem with an encrypted LVM, though I don’t think it is a real problem. It seems that there is an attempt to undo the “/dev/mapper” setup during shutdown. But it should be sufficient to mount read-only, and then just abandon it (not attempt to undo it).

I’m not sure if this is related, but now my system will not shut down at all. If I use the menu to start shutdown, X is quickly killed. I am left at a terminal session. There are no errors. The keyboard works, but there is no response to the “enter” key after I type anything. It only shifts down a line and there is no output. I have to kill the computer with the power button.
There was a kernel update yesterday and that may have started the problem.
I no longer find a way to edit the reboot and shutdown commands. It used to be in KDE/Plasma settings and also in the /etc/sysconfig editor. Those options seem to have been phased out.
I will try a shutdown from a terminal and post back the results later today.

That should not happen. I only rarely see that.

When that happens, instead of using the power button, try CTRL-ALT-DEL. In my experience, that usually works. And if it doesn’t work, then try the power button.

I always try that first, but it had no effect.
Before my terminal initiated shutdown I ran mkinitrd -v. I typically do that manually after a kernel upgrade just to verify that I have a valid kernel. (Yast has left me with no kernel after an upgrade on occasion.)
I ran “shutdown now” and the device-mapper errors were back, but at least it shut down. As far as the errors are concerned, I agree that it is not something crucial. It is only an irritation that causes no damage. Guess I’ll wait and see what subsequent updates bring.

[QUOTE=jdiazgonz;2861695]Getting the same error messages in Leap 42.3 since about one week, after regular update. According to this post the problem must have been solved in 2016…

As do I. Not for Leap, but rather thumbleweed.

You might also see what the effect would be to use the systemctl commands to shutdown since “shutdown -h now” is sudden and uncaring about what else may still be happening and it’s always anyone’s guess what any Desktop does when you click a button to issue a power related command.

To Halt a system (won’t power off)

systemctl halt

To Power Off a system completely

systemctl poweroff

To Reboot a system

systemctl reboot


After months fighting against this issue, and now using Leap 15, it seems the problem is, indeed, related to plymouth. Adding “plymouth.enable=0” to the kernel parameters makes the “device-mapper: remove ioctl on XXXXX failed: Device or resource busy” messages disappear. The problem now is… an uglier boot and shutdown processes, which is like the same than having the initial error messages…

I guess the plymouth process should be stopped earlier during shutdown but no idea how to do it. Any suggestions?

There is an open bug report for this issue:
Bug 1080485

Maybe you could add a comment there about plymouth being involved.

I will add it at bugzilla now and refer back to this thread. I also have this problem and can confirm that disabling Plymouth is a valid workaround.

Thanks. I’ve been checking, and thus far disabling “plymouth” works for me.