Devede sound problem [solved]

I have been using opensuse 11.4 64 bit and devede has been working perfectly up until a couple of days ago. The sound produced in every iso was out of sync very badly and also very slow. I solved the problem, eventually, by putting a check in a check box. Where it needs to be is in the Audio tag in the properties section of the avi file being converted.

Go to the Advanced Options for the file and put the tick in the field: “This file already has AC3 sound (copy audio data instead of recompressing it)”

After doing this my iso was perfect.

I’m guessing that an update had changed this setting, but I would not be sure.

Hope this helps someone :slight_smile:

Sad to say I still have the same problem… your ‘fix’ will only work if the video file you are using has AC3 as an audio track…

In, around line 70 or so, change:

Not positive I had the same problem, but ‘out of sync and slow’ sounds about right and this fixed it.


Hate to ask a silly question but where is “cnf locate” located so I can try this?

Sorry, I meant to ask how can I find that specific file so I can edit it?

To help you with this, and future problems, I’ll pass to you ‘one way’ to go about finding this. There are other ways of course.

One way, if you think the file ‘’ might be a file that was installed with the rpm ‘devede’ is to look at where the rpm package manager (which is called by YaST software management and called by zypper) will have saved all the installation files. Thats actually surprisingly easy to do ! :slight_smile:

Simply open a terminal and type the command:

rpm -qi devede -l

and that should give you a bunch of output, including buried deep in the massive output will be the line


which will show you where the file “devede_video_convert” should be located.

Now if you are at all like me, and find the output of the command I gave far to big to want to scroll through looking for a specific file, then you can put a simple ‘grep filter’ on the output. ie instead use the command:

/usr/share/devede/ | grep convert

and that gives the output


I hope that helps, not only for this question, but maybe also for furture questions.

Very helpful in terms of finding the file, thanks so much! Mine was located in /usr/lib/devede/ Apparently mine was already fixed but I still have the sound problem. I appreciate this help though for future needs.

In this case it reads then possible that your devede comes from a different source OTHER than packman packagers, and you may be able to fix this if you remove your devede version and install the one from Packman packagers and then apply the fix noted.