Devede and Gparted won't load

I have both installed but they won’t load, uninstalled and reinstalled them a couple of times but same result, they just hang trying to launch and then quit the launch process, any ideas what is wrong?

What openSUSE version? What Desktop Environment? Where did you install them from?

Try to run them in a terminal window and post the output.

And maybe your repo list might be interesting, too:

zypper lr -d

Thx for reply, 13.1 KDE and installed them with Yast, not sure how to run them in terminal?

But from which repo?

not sure how to run them in terminal?

Start a terminal (f.e. Konsole, which is in the “Favorites” section in K-Menu), and type in the name of the application, then press ENTER.


I think it is this repo

localhost:~ # devede
DeVeDe 3.23.0 beta1
Locale: POSIX
Using package-installed files
Cores: 1 Virtual cores: 1
Entro en fonts
Creating spumux directory/root/.spumux
Salgo de fonts
Temp Directory is: /var/tmp
home load: /root/.devede
Traceback (most recent call last):
File “/usr/bin/devede”, line 404, in <module>
IndexError: list index out of range

When I enter gparted in root terminal it works but won’t from launcher if that helps you any, thx

You shall run them as user, not root.
We want to find out why they don’t work as user, don’t we?

Also, please show your repo list as already asked.

This is a beta version of devede, so maybe that’s the problem.
Try to install version 0.22.0 from the Packman repo, this should work.

I added Packman and Devede is working good now but Gparted isn’t unless I go Root terminal, heres the message from user terminal which may shed some light on the problem:

baily@localhost:~> gparted
Absolute path to ‘gparted’ is ‘/usr/sbin/gparted’, so running it may require superuser privileges (eg. root).

so running it may require superuser privileges << that is your answer / solution.

You need to run it with a user that has superuser provileges, you can do this by setting up sudo.

GParted is a disk partitioner.

As such, it should run as root. When you launch it, watch your tray for an authentication dialogue, you will need to give root password to launch GParted.

As gparted is an application with a GUI, you cannot run it with sudo on a default openSUSE installation. (it won’t find the current Xorg session in that case)

Use kdesu (for KDE), gnomesu (for GNOME), or xdg-su (should work in any case) to run it:

kdesu /usr/sbin/gparted
gnomesu /usr/sbin/parted
xdg-su -c /usr/sbin/gparted

Those are the tools designed for that job.

But actually the gparted menu entry should launch gparted as root anyway (via pkexec).
What happens if you type this into the terminal window?

pkexec /usr/sbin/gparted

But you could use YaST as well to partition your hard disks.

Ok thx guys I am a little slow replying as was away from box for awhile, your help is really appreciated and fixed it for me, thx very much, Suse is my favorite OS and glad to get it sorted out, thx again!

Yes, that is how it works on my machines, and it then pops up a dialogue box to authenticate with the root password. Sometimes, though, that box is buried under something else, and there is a flashing key icon in the system tray or panel that you need to click on. (in KDE).

Got both working properly from the quick launch bar, set up sudo for kde using this from you guys, thx for the help!
EDITOR=kate kdesu visudo