/dev/video0 problem - no webcam functionality

i try to get my integrated gateway usb 2.0 webcam to work, but i am at a loss … here is
lsusb

Bus 006 Device 005: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
Bus 006 Device 003: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter
Bus 006 Device 002: ID 04f2:b027 Chicony Electronics Co., Ltd Gateway USB 2.0 Webcam
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0461:4d42 Primax Electronics, Ltd
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

and dmesg

usb usb6: New USB device found, idVendor=1d6b, idProduct=0002
usb usb6: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb6: Product: EHCI Host Controller
usb usb6: Manufacturer: Linux 2.6.27.7-9-default ehci_hcd
usb usb6: SerialNumber: 0000:00:13.5
usb 2-1: SerialNumber: 00e04c000001
usb 2-1: USB disconnect, address 2
PM: Starting manual resume from disk
usb 1-1: USB disconnect, address 2
usb 6-1: new high speed USB device using ehci_hcd and address 2
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
usb 6-1: configuration #1 chosen from 1 choice
usb 6-1: New USB device found, idVendor=04f2, idProduct=b027
usb 6-1: New USB device strings: Mfr=2, Product=1, SerialNumber=3
usb 6-1: Product: Gateway USB 2.0 Webcam
usb 6-1: Manufacturer: Chicony Electronics Co., Ltd.
usb 6-1: SerialNumber: SN0001
usb 6-3: new high speed USB device using ehci_hcd and address 3
usb 6-3: configuration #1 chosen from 1 choice
usb 6-3: New USB device found, idVendor=0bda, idProduct=8189
usb 6-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 6-3: Product: RTL8187B_WLAN_Adapter
usb 6-3: Manufacturer: Manufacturer_Realtek
usb 6-3: SerialNumber: 00e04c000001
usb 6-8: new high speed USB device using ehci_hcd and address 5
usb 6-8: configuration #1 chosen from 1 choice
usb 6-8: New USB device found, idVendor=0bda, idProduct=0158
usb 6-8: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 6-8: Product: USB2.0-CRW
usb 6-8: Manufacturer: Generic
usb 6-8: SerialNumber: 20060413092100000
usb 4-1: new low speed USB device using ohci_hcd and address 2
usb 4-1: configuration #1 chosen from 1 choice
usb 4-1: New USB device found, idVendor=0461, idProduct=4d42
usb 4-1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
usb 4-1: Product: Dynex 5-Button Wired Optical Mouse

but then this:
fenris@linux-ec65:~> /dev/video0
bash: /dev/video0: Keine Berechtigung
fenris@linux-ec65:~> su
Passwort:
linux-ec65:/home/fenris # /dev/video0
bash: /dev/video0: Keine Berechtigung

is there a way to fix this … thanks in advance … theo

Hi,

uhm…what was your intention with “executing” the device?
Your camera model is listed as fully functional with the uvc-driver. This driver came bundled with the 2.6.27. kernel. Have you tried luvcview or guvcview? Does your camera work with ekiga or cheese?

my intention was that i did not know what i did … i am a gui kinda guy, code still somewhat eludes me … anyway:

got cam listing and picture in kopete …
cam listing and no picture in skype …
cheese’s got a picture, but it’s all messed up (only half of the viewing area is used, rest is black … tried to change resolution, no affect) …
camorama doesn’t find the cam …

luvcview generates:
fenris@linux-ec65:~> luvcview
luvcview version 0.2.1
Video driver: x11
A window manager is available
video /dev/video0
Unable to set format: 22.
Init v4L2 failed !! exit fatal

guvcview:
fenris@linux-ec65:~> guvcview
bash: guvcview: command not found

theo

:wink: no problem. What would you like to do with the camera?

strange. Can u post the output of “luvcview -L”? It seems that V4L2 failed to set the requested format. The command will list all available image formats. You can try to set a format explicitly with e.g. “luvcview -f yuv”

guvcview is usually not installed…maybe you need to compile it but basically it is an gui-improved version of luvcview. It’s pretty useful to test your cam.

fenris@linux-ec65:~> luvcview -L
luvcview version 0.2.1
Video driver: x11
A window manager is available
video /dev/video0
/dev/video0 does not support read i/o
{ pixelformat = ‘YUYV’, description = ‘YUV 4:2:2 (YUYV)’ }
{ discrete: width = 640, height = 480 }
Time interval between frame: 1/30, 1/20, 1/15, 1/10, 1/5,
{ discrete: width = 352, height = 288 }
Time interval between frame: 1/30, 1/20, 1/15, 1/10, 1/5,
{ discrete: width = 320, height = 240 }
Time interval between frame: 1/30, 1/20, 1/15, 1/10, 1/5,
{ discrete: width = 176, height = 144 }
Time interval between frame: 1/30, 1/20, 1/15, 1/10, 1/5,
{ discrete: width = 160, height = 120 }
Time interval between frame: 1/30, 1/20, 1/15, 1/10, 1/5,
{ discrete: width = 1280, height = 800 }
Time interval between frame: 2/15, 1/5,
{ discrete: width = 1280, height = 1024 }
Time interval between frame: 2/15, 1/5,

like to use the cam with kompete and skype … have got many friends back in europe …

how would i compile guvcview … i tried to install it off the net, but i ran into dependency issues (some libraries were missing) …
thanks for your help … theo

Try “luvcview -f yuv”. It looks like the uvc driver is working correctly and it was able to report all supported video modes. Unfortunately the default video mode for luvcview is mjpeg which isn’t supported by your cam.
If you need help concerning the cmd-line parameters of luvcview “luvcview -h” might be your friend. If u have a picture with the above command your problem isn’t hardware-related and you should ask a skype forum for more help.
If luvcview isn’t able of producing a nice picture then you might ask the uvc mailing list. This one can be found here clickedy-click.

luvcview -f yuv starts the cam in a separate window … looks okay, though the window frame flickered
is support for my webcam in the making? … theo

Your cam seems to be working…so what kind of support? Look at my previous post.

still have got no picture in skype, and
got a weird size issue in cheese … i’d like to send some video feed to friends back in europe, but the webcam software i have got (cheese, camorama, camelot) do not work properly or not or all …
can i record in luvcview?
how do i compile guvcview (missing some dependencies, like libSDL, libgtk+2, libportaudio, libgtk-x11-2.0.so, libpng12.so.0)?
theo

luvcview nor guvcview can solve your problem but as far as I remember both of them are able to record a video. there are some buttons on the gui.
your cam is working. these two tools are useful to test your hardware/driver combination. If skype isn’t able to produce a proper picture then your problem is skype :slight_smile: I’m sorry but I guess the skype developers are the only one who can help on that.

Index of /repo