/dev full due to preloadtrace.log

Hello,

I have searched into the forums and the web before posting, and I apologize if my question is trivial, and for my english.

Just after boot of my opensuse 11.2, the /dev is less than 10% full. But, as time runs, it becomes full, leading to problems. I have searched for the reason, and find an ever growing file, named preloadtrace.log.

May I rotate this log as other ones with webmin (and should I use special commands to do it), or is it possible to avoid the creation (or the filling) of this file ?

Thanks a lot
Your sincerily

Are you sure you are referring to /dev (device files) and not /var?

Hello,

thanks for your help.
Actually, I think that the right path is /dev/shm/preloadtrace.log. I’m pretty sure, since /var is located on the “/” mount point, which is different from the “/dev” one. And this later becomes full, when “/” remains normal. I will check as soon as I will be back home, since it is my home server.

Bests regards

try using YaST to remove preload…i can’t imagine why/how you might
benefit from it on a server…

and, anyway something is wrong with the way it is installed because
unless i’m wrong (and i may be) it shouldn’t be doing two things:

  1. logging to /var
  2. growing very large (have you LOOKed at the log file to see what (i
    guess) error it is reporting over and over and over…i guess it is
    trying to preload something that no longer exists where it used to)

on the other hand, preload may be a critical part of a server and if
you follow my advice you will be sorry…in which case just use YaST
to install it…but, still you need to find out why it writes to
/var, and what it writes…find the config file, i guess it is
corrupted…maybe.


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

Hello,

I have more information:

I confirm that the path is /dev/shm/preloadtrace.log.

It contains, at the beginning, thinks like:
0.025 394 S01boot.startpr fork 450
0.025 450 S01boot.startpr execve /usr/bin/ionice
0.032 450 ionice open 3 /etc/ld.so.cache
0.032 450 ionice fstat 3
0.032 450 ionice read 3
0.032 450 ionice open 3 /lib64/libc.so.6
0.032 450 ionice read 3
0.032 450 ionice fstat 3
0.032 450 ionice execve /sbin/preload
0.042 450 preload open 3 /etc/ld.so.cache
0.042 450 preload fstat 3
0.042 450 preload read 3
0.042 450 preload open 3 /lib64/libpthread.so.0
0.042 450 preload read 3
0.042 450 preload fstat 3
0.043 450 preload open 3 /var/cache/preload/prepared


then:
0.504 485 modprobe open 3 /etc/modprobe.d/10-unsupported-modules.conf
0.504 485 modprobe fstat 3
0.504 485 modprobe read 3
0.504 485 modprobe open 3 /etc/modprobe.d/50-blacklist.conf

then:
1.734 714 devkit-disks-pa open 3 /usr/lib64/libreiserfs-0.3.so.0
1.734 714 devkit-disks-pa read 3
1.734 661 devkit-disks-pa open 3 /usr/lib64/libreiserfs-0.3.so.0
1.734 663 devkit-disks-pa open 3 /usr/lib64/libreiserfs-0.3.so.0
1.734 716 devkit-disks-pa open 3 /usr/lib64/libreiserfs-0.3.so.0

In short, it seems to log about everythong done on my server.
Please, can you tell me how to configure it to stop that ?
It seems that some distribs have a /etc/preload.conf (found in Google) , but I’m not sure that it is the case for opensuse, and haven’t find an opensuse preload tutorial.

Thanks for your help
Best regards.

Seriously: boot this machine down and get some knowledge on how to administrate a Linux-system. No offense meant, really.

Even an expert does not know everything, but if you are running a server, you should at least know how to research things, for example what preload is, if there’s a preload.conf on your system, how to manage logs (the approach to simply switch of logging makes my hair fall out!), what role /dev/ has within the filesystem hierarchy etc.

Again: no offense meant.

Thanks for your very kind answer.
I apologize for my dumb questions.
I believed, previously, that forum like this one are partially existing for helping people to become wiser. It seems that it is not your opinion. It seems also (http://forums.opensuse.org/english/get-help-here/install-boot-login/450292-clonning-hard-disk-disk-id-problem.html) that your advices are pretty simplistic. No offense meant.

I know that turning off log is not a good idea. As I mentionned previously, I’m not a linux guru, and the server is my home server, just for my kids and me. It is not a professional one. As I also mentionned, I have searched the web for tutorial on preload, or even substantial documentation, without success. But I will searched for a preload.conf on my server, and try to find how to configure it by myself.

Don’t waste your precious time answering me.
No offense meant.

I don’t quite understand why you seem to have a problem with my answer. A server interacting with the internet is quite a critical setup insofar that it is an attractive target for attacks and one should be able to control it, plus being able to research on a problem is really a must. DenverD for example suggested to simply switch off / remove preload, while stating that this might be the wrong approach, for it might be a critical application for a server - which it is not, this could have been researched by you (for example by simply checking the package information via ‘zypper if preload’). These are very basic and simple approaches, and when administrating a server, one should be capable of that. If not, one should learn how to manage a server offline first - again: it’s an interesting target, that’s what I was referring to when recommending to boot this machine down.

As for my advices being simplistic: thank you, I take that as a compliment. :slight_smile:

Try appending preloadlog=/dev/null to the kernel options before booting.

On 2010-11-24 10:06, hdlbq wrote:

> I know that turning off log is not a good idea. As I mentionned
> previously, I’m not a linux guru, and the server is my home server, just
> for my kids and me. It is not a professional one. As I also mentionned,
> I have searched the web for tutorial on preload, or even substantial
> documentation, without success. But I will searched for a preload.conf
> on my server, and try to find how to configure it by myself.

Have you installed things outside of the distro?

What configurations have you changed?

If you have installed nothing and changed nothing, I would think or a bugzilla.

At worst, i might know how to block that file from being created so that
“somebody” complains.

For the record, I’m an experienced linux user, and a contributor. I know a
lot - but I don’t really know what preload is. I don’t need to. It is quite
normal, INMO, to know about certain areas and not others. I can make
guesses, I may know where to start looking. But real knowledge about
preload, no, I don’t have, and I don’t believe anybody knows - or they
would have told you what the problems is or might be.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

kalle@hoppers:~> zypper if preload
Daten des Repositorys laden ...
Installierte Pakete lesen ...


Informationen für Paket preload:

Repository: @System
Name: preload
Version: 1.1-6.9.1
Arch: i586
Hersteller: openSUSE
Installiert: Ja
Status: aktuell
Installierte Größe: 60,0 KiB
Zusammenfassung: Preloads Files into System Cache for Faster Booting
Beschreibung: 
Preload lists files to load into the system cache. This shortens system
boot time if used correctly.

hdlbq wrote:
> Don’t waste your precious time answering me.

why are you still asking questions?
the only real question here is: Why are you using preload?
you don’t know, and neither does anyone else here…as i said earlier:
“i can’t imagine why/how you might benefit from it on a server”

uninstall it and see what happens…


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

On 2010-11-24 14:07, DenverD wrote:
> hdlbq wrote:
>> Don’t waste your precious time answering me.
>
> why are you still asking questions?
> the only real question here is: Why are you using preload?
> you don’t know, and neither does anyone else here…as i said earlier:
> “i can’t imagine why/how you might benefit from it on a server”

For the same reason we all do: because suse installs it:

cer@Telcontar:~> rpm -q preload
preload-1.1-6.9.1.x86_64

I have it installed, but I did not do it. And it certainly runs:

Telcontar:~ # chkconfig boot.startpreload
boot.startpreload on

> uninstall it and see what happens…

That something will probably break. Notice that it is not documented:

cer@Telcontar:~> rpm -ql preload
/etc/init.d/boot.startpreload
/etc/init.d/earlyxdm
/etc/init.d/stoppreload
/etc/init.d/waitfornm
/sbin/preload
/sbin/preload-client
/sbin/print-bmap
/usr/bin/prepare_preload
/usr/bin/waitforidle
/usr/sbin/stop_preload
/usr/share/doc/packages/preload
/usr/share/doc/packages/preload/bootfaster.diff
/var/cache/preload

No man page, no readme. It is one of those things the devs at opensuse do
for our benefit, without asking us >:-)

A search provides the culprit:

cer@Telcontar:~> grep preloadtrace.log /etc/init.d/*
/etc/init.d/boot.startpreload: preloadlog=/dev/shm/preloadtrace.log

Another look at that file tell us who wrote it:

Copyright (c) 2007 SuSE GmbH Nuernberg, Germany. All rights reserved.

So certainly the suse devs are writing the log to /dev. As a hack, the OP
could edit that file to write the log somewere else (with a symlink, lest
something else breaks), and also write a Bugzilla so that the devs that
configured this know that it breaks and solve it.

And please, don’t kill the messenger (hdlbq) >:-)


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

What about turning back on the following service?

chkconfig stoppreload on

good answers Carlos…i continue to learn more and more…


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

How big is this file? How much disk have you devoted to root?

/dev is normally a virtual directory and does not reside on the disk it contains dynamic data about devices attached to the system.

Remember everything in Linux/Unix is a file.

On 2010-11-24 17:06, please try again wrote:
>
> What about turning back on the following service?
>
> chkconfig stoppreload on

It should be on, and it runs when halting the computer, so it has no effect
on this problem (/dev is dynamic)


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

On 2010-11-24 16:56, DenverD wrote:
> good answers Carlos…i continue to learn more and more…

Me too… what I posted I learnt the minute I wrote it :wink:


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

And what exactly would it “break”? I posted the package description here, so it’s quite clear what it’s for. Again:

Preload lists files to load into the system cache. This shortens system
boot time if used correctly.

I wouldn’t consider a longer boottime breakage.

Do you (or anyone else) have a preloadtrace.log in /dev? Because I do not, and actually /dev is not a proper place for logfiles at all (hence the name). Actually I don’t even have a preload-log at all (although it is active on my system as well).

On 2010-11-24 20:06, gropiuskalle wrote:
>
> And what exactly would it “break”? I posted the package description
> here, so it’s quite clear what it’s for. Again:
>
>
> Code:
> --------------------
> Preload lists files to load into the system cache. This shortens system
> boot time if used correctly.
> --------------------

I don’t know exactly what files it caches.

> I wouldn’t consider a longer boottime breakage.

I’m not an expert on preload. I know my system uses it, not why and how. It
is not important to me.

>
> robin_listas Wrote:
>> So certainly the suse devs are writing the log to /dev.
>
> Do you (or anyone else) have a preloadtrace.log in /dev? Because I do
> not, and actually /dev is not a proper place for logfiles at all (hence
> the name). Actually I don’t even have a preload-log at all (although it
> is active on my system as well).

You just look into the setup script written by the suse devs, and you will
see that the log is certainly there. Complain to them that the place is the
wrong place to have a log, not to me…

It can be that the log is not always written. Check the script… it
appears that some kernel command line options can modify its behaviour.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)