/dev/disk/by-id/ cant boot

having booting problem because of detached hdd
os 11.0 screen states
waiting for /dev/disk/by-id/usb-seagate_desktop

I have a usb hdd count not get it mounted so in yast i put /media as the mount point in the yast–>partition–>sdb3. well i do NOT have the hdd drive because i took it back to the store

I DO have root and can get in the recover mode but I DO NOT know command I am a noob

Edit the file fstab (it’s at /etc/fstab) and take out the line for mounting that partition in /media

You can edit from the openSUSE live CD, or any Linux live CD like Knoppix, Mandriva, Ubuntu, SystemRescueCD etc.

You can also edit from the installation dvd but you have to use the non-gui editor on that one, easier to use the live CD method if you are a GUI fan.

thx 4 info

i login with root pwd, i type edit fstab in the dev directory. i comment each line that stated /dev/disk/by-id

NOW i get a new problem it made if pass that error and went to a small box in upper left.
box: could not start kstartupconfig. check your installation i click on okay button now I am at login screen which has root as user name i click on user icon and type password. it goes back to the box could not start kstartupconfig. check you installation

how do I fix this

just remove the line that points to /media (at the end)

the file is not in /dev it is in /etc

Ok question did you remove all the lines??

Had you installed Suse on that hard drive??

oops i edit the /etc/fstab file sorry not /dev/fstab

i comment each line that started with /dev/disk/by-id/
only lines not commented are

  • proc /proc proc default
  • sysfs /sys sysfs noauto
  • debugfs /sys/kernel/debug debugfs noauto
  • usbfs /proc/bus/usb usbfs noauto
  • devpts /dev/pts devpts mode=0620,gid=5

i install OpenSuse 11.0 from a cd as new installation

installed 10.3 full new install
installed 11.0 full new install
tried to install 11.1 as upgrade failed
reinstall 11.0 as new install reformatted
tried to install 11.2 as upgrade failed (thought it would work)
reinstalled 11.0 as new install reformatted (as new)

You do NOT want to remove all the lines than nothing gets mounted!!! :open_mouth:

Need to boot from a CD/DVD to the command line edit the /etc/fstab again and un-remark all except the line that references the drive that is no longer there. It will have the mount point /media after the long part that names the drive.

i booted with 11.0 used terminal login as su

vi /etc/fstab only lines i see are the 4 lines i sent you the uncommented lines


You need to run the repair option from the install disk to get the file set up correctly again.


k ran from cd automatic repair now i have this in the fstab
i still get the same box on the screen
kstartupconfig. check you installation



#dev/disk/by-id/scsi-SATA_ST960822A_3LF32WTX-part1 swap swap defaults 0 0
#/dev/disk/by-id/scsi-SATA_ST960822A_3LF32WTX-part2 / ext3 acl,user_xattr 1 1
#/dev/disk/by-id/scsi-SATA_ST960822A_3LF32WTX-part3 /home ext3 acl,user_xattr 1 2
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
#/dev/disk/by-id/usb-Seagate_Desktop_2GHKLAM3-0:0-part1 /media/usb15 vfat users,gid=users,umask=0002,utf8=true 0 0
#/dev/disk/by-id/usb-Ext_Hard_Disk_ABCDEF0123456789-0:0-part2 /media ext3 defaults 1 2
/dev/sda2 / ext3 defaults 1 1

i uncommented the first 3 line and commented the last line now it boots fine

Thank You everyone

Good work, well done

I am having the same problem, and despite trying your suggestions i still get

gedit:1529): Gtk-Warning **: cannot open display:
gnomesu:1535): Gtk-Warning **: cannot open display:

I get a different number each time but nothing else changes.

I’m confused this does not seem to be the same problem. Maybe you should start a new thread and say exactly what the problem is and what you have done to try and correct it.