Detected 1 file conflict: File /usr/lib64/sasl2/ from install of

Detected 1 file conflict:

File /usr/lib64/sasl2/
from install of
sasl2-kdexoauth2-18.08.1-2.1.x86_64 (openSUSE-Tumbleweed-Oss)
conflicts with file from package
sasl2-kdexoauth2-3-18.08.1-1.1.x86_64 (@System)

Saw that too. Replied yes, since I wanted the newer package to rule.

Got that too. Tried to remove the sasl2-kdexoauth2-3 package, but that would remove a lot of other packages, so I did like Knurpht.


Not clear to me. Who tried?

Did you answer “yes” and as a result YaST tried to remove and came with the new message?

Or, you stopped the installation and then you tried to remove the package manually?

I’m sorry, my reply wasn’t very clear.
I interrupted the installation and I tried to remove the package manually.


That is NOT w hat Knurpht advised. Saying yes to YaST wil let YaST to change vendor for the product and install the version from Packman to replace the one there is.

What you do is completely de-install it with all the consequences.

hcvv, if you read my reply carefully, you’ll see that I said that I tried to remove the package, then - when I saw that removing that package would have uninstalled a lot of other packages - only then I decided to do what Knurpht did. That is: I did again a “zypper dup”, and when it proposed me the conflict I answered “yes”.

Is it any clearer now?


It is clearer now that your report after Knurpht’s advice was manily about what you did before Knurpht’s advice.

So you “did like Knurpht” and did that work to satisfaction?

hcvv, I know you’re a moderator here but it seems to me you’re nitpicking every single bit of what I say to find something wrong, and I really don’t know how or why I should deserve it.
I’ve been a longtime member here and I’ve always tried to post useful sentences.
In this thread I was specifically replying to the OP, just to say “you’re not alone” and detailing what I did to resolve the problem.
And yes, it did solve it.
The fact that I referred to Knurpht’s post was just because he posted before me and I applied the same solution.
Is there something wrong with reporting my own experience with the same problem?
I don’t think this is the first time I see a thread here where somebody replies to a question with his own experience even after another post already provided a solution. I’ve seen plenty of this, actually, and it does not worry me a single bit.
This is a forum after all, not a Q&A site where everything must be trimmed down to the mere solution. Or is it?

I hope we can stop this thread here as we’re quickly going OT. If you have problems with me specifically you can write me a PM.


Yes, I saw that conflict.

I canceled out of “zypper dup” and checked (using Yast). The second of those packages is no longer in the repos. So I deleted it, and repeated the “zypper dup”.

This is apparently a bug (a very minor bug). When “sasl2-kdexoauth2-18.08.1-2.1.x86_64” was added, they forgot to generate a rule that would automatically delete “sasl2-kdexoauth2-3-18.08.1-1.1.x86_64”.

Actually, the easy step would be to just say “yes” to the conflict, and delete the other package afterwards. Or don’t bother to delete it, because they will probably fix that bug and auto-delete in within the next few days.

There is actually an open bug report on this Bug 1110822.

i am sorry you take my posts as negative. I missed that you reported about what you did before you did the correct thing. I really read it as if you tried to remove the package after Knurpht gave his advice. You explained that and it is clear now. And I missed completely that your problem was already solved at that moment in time. Sorry for not understanding that.

And to your other remarks. IMHO it is not only a question of simply Q & A. Many people do not only like it to have an answer, but also to learn why that answer is working where their own approach did not. They want to understand and learn from answers.

BTW, I am a mod, but I am also a member like you. And while it might be difficult at times to differentiate between those roles, I certainly was not moderating your posts.