Detailed CPU usage

Hi I’m running OpenSuSe 11.1 32-bits GNOME on an HP Pavilion dv5035nr laptop, with a AMD Turion64 ML-40 (2.2GHz) processor, 1 Gb PC2700 RAM and ATI Radeon Xpress 200M

I’m getting extremely high CPU reading using System Monitor. With just firefox, a terminal and the system monitor running I’m getting between 20 and 50 %. Whenever I’m using banshee, openoffice, yast, etc I get huge spikes that reach 100% at times!.

I don’t think this is normal behavior. Is there a way to get a detailed CPU usage process list, so I can find the culprit?. At this point I blame it on my b43 old firmware and the gnome configuration…but I’m unsure.

Thanks

Andres

open a console and type top.
Will show cpu usage.
In kde you can also use Alt+Esc not sure if it works in gnome

/Geoff

  • geoffro wrote, On 01/28/2009 05:46 PM:

> In kde you can also use Alt+Esc not sure if it works in gnome

Ctrl+Esc

Uwe

But since 11.0 the process table GUI won’t display CPU % usage, as before. Have to see it in top.

If you have dual-core, pressing 1 when running top will show sumary lines for each core.

Hmm… for me it shows. Maybe you need to add this column by doing a right click to one column and selecting Show Column CPU %.

On 01/30/2009 ram88 wrote:
> Hmm… for me it shows. Maybe you need to add this column by doing a
> right click to one column and selecting -Show Column CPU %-.

Same here.

Uwe

htop worked great, thanks

There’s a utility called powertop (LessWatts.org - Saving Power on Intel systems with Linux) that will show really detailed CPU usage, plus suggestions for improvement. If you run it on a laptop, it will also track actual power use (its main purpose), but it will give the process & processor info on any machine.

Tried that, but there is no such column. I even hid most (all except process name and PID) to see all column names that appear in the drop-down menu, but nothing. It also doesn’t seem to be a zero-width column.

And, if you remove all columns there is no way to set them back, as there is no column to right-click. I can’t even create a new worksheet, all file options are grayed out. Ah, the joys of modern computing…

Edit: closing and opening system guard reset the worksheet, but still no CPU usage %. :confused:

KDE Control Center says I’m using KDE 3.5.9 release 49.1