Desktop won't start after update to 11.4

I have been running 11.4 for a while and last night I put on 18 updates which required a restart. The boot now drops me to a command prompt login instead of starting the desktop login process. How do I fix this?

Don

Hi,

I’m not an expert, but how did you know it were 18 updates ?

Mike

KDE has a notification area which told me there were 18 updates available and gave me the option to apply them which I did. At the end of the update, I was notified that a restart was required which I did. The boot process that is displayed doesn’t show any errors, except that the vboxdrv failed, which always happens whenever I get an update. I am left with a command line login prompt. I tried an init 5 but get the same results.

What video? Did you try reinstalling the proper driver.

There are a few more questions the answers to which could help:

which kind of computer do you use ?

For your updates, did you only include the openSUSE site,
or possibly other WEB sites as well (and if any, which) ?
The question behind that is, did you only install ‘official’ updates ?

Mike

I keep forgetting. After a kernel update I have to reinstall the Nvidia driver and recompile the Vbox driver. Did it and am well again. Don’t know why I can’t remember.

On 11/11/2011 08:06 PM, DonMLewis wrote:
>
> I keep forgetting. After a kernel update I have to reinstall the Nvidia
> driver and recompile the Vbox driver. Did it and am well again. Don’t
> know why I can’t remember.

Just remember that rebuilding out-of-kernel drivers after a kernel change IS the
penalty for using out-of-kernel drivers!