desktop slow and bloated

Konqueror is just slightly better than Firefox. Example: I spin the scroll wheel (middle button of mouse) to move down the page – nothing. So I do it again – nothing. So I spin it back the other way – still nothing. So I click the go back one page arrow – nothing. So then I’m sitting here perplexed, and then the page goes down, stops, goes down some more, stops, then goes back up, stops, then goes back a page.

I’m here typing this post, I’m pushing keys, screen stays as it was, after two or three seconds, words appear.

Can someone tell me what to do to fix this? I’d really appreciate it.

Why don’t you check top and see if something is eating up your resources?

I agree with chief_sealth, the first thing you should do is to open up System Monitor and check your CPU and RAM usage. Post back the results.


If System Monitor takes forever to open (it sometimes does that at the most ackward moments), open a Konsole Terminal and run ‘top’. Post back the results.

When I run “top” in the konsole, ti show more info than system monitor does – but I’m not able to copy either one. Konsole lets me select the data (system monitor doesn’t), but as soon as I let go of the left mouse button, it deselects.

So I need someone to tell me how to copy this output.:confused:

Hit “q” - it will stop the auto-refresh and bring you back to the prompt. You can then copy/paste the contents.

The system load veiwer widget on the menu bar says cpu usage is fluctuating between 3 to 8%, ram usage 55-56%, and swap is 2% (the figures change as I’m looking at them). The RAM viewer widget shows physical: 276.9 KiB 649.3 KiB, and Swap: 16.0 KiB 1,004.0 KiB.

Seems like I recall that 11.1’s system monitor showed an actual running graph (I can’t think of the name of that type of graph, but it was sort of like a running EKG reading) that showed the activity of each cpu individually. Can I get that installed on 11.2? What’s it called?

top - 15:31:57 up 37 min, 3 users, load average: 0.14, 0.16, 0.25
Tasks: 133 total, 2 running, 131 sleeping, 0 stopped, 0 zombie
Cpu(s): 20.5%us, 4.5%sy, 0.0%ni, 74.7%id, 0.0%wa, 0.3%hi, 0.0%si, 0.0%st
Mem: 511328k total, 444296k used, 67032k free, 10332k buffers
Swap: 1028120k total, 16396k used, 1011724k free, 159392k cached

1322 root 20 0 124m 62m 4044 S 30 12.5 4:35.50 Xorg
2091 randall 20 0 412m 124m 26m S 8 25.0 5:12.48 firefox
1564 randall 20 0 270m 36m 25m S 6 7.3 1:14.19 plasma-desktop
2561 randall 20 0 117m 20m 10m R 2 4.1 0:49.90 npviewer.bin
4742 randall 20 0 97360 18m 13m S 2 3.7 0:09.40 konsole
1555 randall 20 0 235m 19m 15m S 1 3.9 0:05.48 kwin
4767 root 20 0 2564 1020 772 R 1 0.2 0:09.90 top
4884 randall 20 0 2436 1016 712 S 1 0.2 0:08.21 ksysguardd
1 root 20 0 1940 616 568 S 0 0.1 0:01.70 init
2 root 15 -5 0 0 0 S 0 0.0 0:00.00 kthreadd
3 root RT -5 0 0 0 S 0 0.0 0:00.00 migration/0

I had similar issues when my display drivers wernt working properly.

Is that the output when you get the slow scrolling in Firefox?


When the system is booting up, there’s a line of verbose that says " ‘sd’ driver needs updating use bus_methods." To what does that allude to? Does it have anything to do with display drivers not working correctly?

Although you are using some swap memory (a mere 16 MB), I don’t think it’s CPU cycles or swapping that is causing this.

Unless you notice that the harddrive is spinning continously (which would be an indication of draining resources of some kind), I would say that this is a display driver issue.

Is “display driver” the same thing as a graphics card driver? If so, please see my thread in the Hardware forum:

Where/how to get nVidia driver? (Multi-page thread 1 2 3)

17-Nov-2009 06:01
by malcolmlewis Go to last post

I had this problem too on more than one system. I don’t know why, but option “activate smooth scrolling” (or something like this, I’m using german locale) is put on as default which causes these problems on any system I tried yet.

In Firefox, go to “Edit” -> “Settings” -> The rightmost icon and then try unchecking this option.

Well, BuddelBoB, as far as I can tell for the few minutes it’s been since I followed your directions, you’re right on the money. This sucker seems supercharged. Thank you very much.