Desktop shortcut won't start my app

This will be very stupid, however…
I installed matlab for linux via the installer. When I type into the terminal as normal user:


the program starts perfectly fine.
I want now a click-able icon on the desktop (KDE3.5). So when I produce the application shortcut, no matter how I do define the command, it will not start.
I did put
Command: matlab (tried also matlab glnx86)
I joined in advanced: start in terminal (but it does not work either)
I did join the complete and correct path…
Somehow…I do not understand why it starts from the console in user-mode without problems with the command but not while using a shortcut.
Any suggestion?

Is there an application launcher in /usr/share/applications?

Can you launch any other application from desktop? Is it only that one?

Where did matlab get installed? You may need to provide the complete path.

@chief-sealth: no there isn’t any.

@ah7013: yes it is the only shortcut where I encounter the problem. All others run fine.

@gogalthorp: I did give the full install path until the program itself, either with the command or with the path, none worked. The funny thing is: when I am in yakuake (console) and I type in the normal command “matlab” without anything else, it starts immediately. It does so by building a shell /bin/sh and then starts up the application. The install is is /usr/local/share/mathworks. I have as user read and write access (limited to this directory), that’s why it does start from terminal and works flawlessly. File permissions in Yast are set to secure. I have also STATA in /usr/local/STATA and it does have a shortcut on the desktop. No problem at all.

Can you look at the desktop entry via the command line (maybe it needs to start in a terminal?)

ls ~/Desktop
cat ~/Desktop/<shortcut_name>.desktop

Hi Stakanov,

I believe what you are looking for is the -desktop option.

Here is my desktop entry in /usr/share/applications

[Desktop Entry]
GenericName=Mathworks Matlab R2010a
Exec=matlab -desktop