desktop login


I installed mate desktop via yast, but it does not show up as a login choice such as plasma5 or gnome do.

So I used zypper ar -r

and it says already installed. What am I missing? I am perfectly happy with kde but just like to tinker.

the above command does not install anything it just adds the mate repo, did you install any mate packages?

zypper in mate-desktop

No I did not. I am using the command you suggest and it is retrieving now seems to take some time.Will that finish the job?

Its been a at least a half hour and it still is retrieving???

It has finished downloading and instaling the mate repository. I shut down the computer, re-booted and there is still no mate choice offered at the login key.

What to do now?

are you installed any display manager?, mate doesn’t show login screen, that’s done by display manager like gdm, lightdm, etc.

I will check it out. Thank you.


I just installed budgie desktop to suse 42.2 in the time it takes to say jumpin jack flash. No problems and shows up as choice in login site.

Ok installed light gdm and its dependicies re-booted still no mate at the log-in.lightdm was already installed.

Just install them. Select "Patterns

I have a lot to learn about installation on suse but found this in a suse blog, went to Patterns in yast installed there and voila the log-in for Mate is there. Mate desktop is

now installed and working.

I am still wondering about the entire process here though any explanation would be welcomed. As to the log in there is also Gnome Classic but it seems no different

than Gnome. I wonder why that is? The good thing here for me is as to the accomplishments so far is I see no advantage at this point of Ubuntu Unity 16.04 lts as

I am able to run all these different desktops on Leaf 42.2. I guess I could try adding Cinnamon here too but Plasma 5 suits my needs. The budgie install was a whiz.

and a neat desktop as well.

Thanks all.

as you’re new to opensuse I recommend using YAST until you get the feeling of the OS
afaik mate is in the main repo and that extra repo you added contains updates not found in the main repo as after a release LEAP only does security and bugfix updates
if you’re trying out desktops I can recommend lxqt just search YAST for it, as it’s QT5 based it doesn’t need extra packages (you probobly didn’t have most of gtk2 installed that’s why mate downloaded so much)
unlike other Linux distro’s opensuse comes with a lot of desktops one that I use on and off is Window Maker and that is one tiny DE

Thanks for your reply. Trial and error= learning.