Desktop LAN cable not detected

Just got a new desktop and finally sorted out a dual boot with Windows 8.1 and Suse 13.1 but upon opening Suse it doesn’t want to detect my LAN cable so can’t get to the internet…not ideal! So what’s the best/easiest option?

Now, I can pop into PC world later, will anything from here do?

Ideally, I’d like something very simple, will a USB one be automatically detected? I obviously need something that I don’t need to go online to access the drivers for!! I suppose I could download drivers from the internet on windows and put them on disc but want something easier if possible. I’m not sure if I have a spare PCIe slot, either. I’ve never installed a PCIe device, would I need to take the back panel off the machine to check?

Many thanks :smiley:

I’ve done some reading and found my device ID is “enp3s0” but if I run “dhcpcd enp3s0” I get an error

“err, enp3s0: ioctl SIOCGIFHWADDR: No such device”

First you say your system dos not detect the device, but you fail to explain why you think so.

Now you say the system found it. Did you use YaST > Network Devices > Nework Settings to see if it was detected? Did yo use the same to try to configure it?

Please always report what you did, what you expected to get with it and what you get instead.

And please, instead of telling stories like I run “x y z” and I got “a b c” copy/paste it from the terminal (including prompt, command, output and next prompt) in between CODE tags in the post. You get the CODE tags by clicking on he # button in the tool bar of the post editor.
In your case, not having a network connection, first past it into a file in an USB stick or likewise.

Thanks for the reply HCVV. I did indeed go into YaST > Network Devices > Nework Settings to see if it was detected.

Currently under that menu and global settings" It’s currently set to “traditional method with ifup”

overview -
Device name: enp3s0
Started automatically at boot
IP address assigned using DHCP

Under hardware the module name is r8169

Apologies about not doing the code as the format.

Edit - just rebooted and seems to be working!!! For now at least!

Many thanks! Now just to sort my lack of sound, media stuff and my graphics card rotfl!