desktop is hogging bandwith.

I am running OpenSuse 11.2 on my desktop here in the office and when I download anything, other users are complaining over very slow internet speeds.
My download speed seems to be the same as other users using Windows, but downloading from a windows machine does not cripple the network.
So is there something in my network setup that can be tweaked so that I do not cripple the network when downloading ?

All feedback will be much appreciated.

Downloading with a browser over http or ftp - is that what you are meaning?

Yes that is the issue. I have tried using Aria2c and capping bandwith, but even whith this in effect, I am still crippling the network.

Have you looked a kget or
flashgot (ffox extension)

You can probably throttle those, I’m not certain though.

Yes I have tried these, but even with throttling in effect i am crippling the network.

I did just check with kget and you can throttle.
But if you already tried and the issue continues, I have to say I have never come across this before. But I suspect you need to be explain in more detail, how the network is set up and the computers access it

Ok here is a short description of the setup:
OpenSuse machine is sitting on corporate LAN network behind Cisco ASA firewall. On the same network and on the same switch is about 25 windows desktops.
When I download any file from my linux machine, the whole network is experiencing very slow internet speeds.
Whin I do the same download from a windows machine next to me there is no problem.
I get the same download speeds on both machines, but somehow the linux machine is crippling the network.
Hope this description helps.

And thanks again for the feedback.

xldata wrote:
> All feedback will be much appreciated.

was there any change after you disabled IPv6?


Is there anything on your switch that does traffic management & priorities? It could be that the switch is configured to give requests from specific IP(s) priority, and your linux box just happens to have one. Massive coincidence though. Give a win box the same IP and see what happens.

I’ve never heard anything like it, perhaps you could investigate using wireshark (packet sniffer) or easier would be if your switch has some management capability, perhaps it has logs you could look at?

IPv6 is now disabled and the problem has disappeared :slight_smile:

Thanks for the feedback and suggestions always a pleasure when the response is so quick.

Darn. So easy to overlook the obvious.