Desktop icons on the wrong screen

I have 2 monitors. My icons and the taskbar/panel used to be on the left screen.

Now I don’t know why but they are been moved to the right screen. The position and order is the same as it was on the left screen.

I moved them yesterday back to the left screen and today again they are in the same order on the right screen.


> inxi -Gaxxxz

Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Micro-Star MSI driver: amdgpu v: kernel bus ID: 01:00.0 
           chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: amdgpu,ati 
           unloaded: fbdev,modesetting,radeon,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") 
           s-diag: 1055mm (41.5") 
           Monitor-1: DisplayPort-1 res: 1920x1080 hz: 60 dpi: 96 
           size: 509x286mm (20.0x11.3") diag: 584mm (23") 
           Monitor-2: DisplayPort-2 res: 1920x1080 hz: 60 dpi: 96 
           size: 510x290mm (20.1x11.4") diag: 587mm (23.1") 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.33.0 
           5.3.18-lp152.57-default LLVM 9.0.1) 
           v: 4.5 Mesa 19.3.4 direct render: Yes 

> cat /etc/os-release

NAME="openSUSE Leap"
VERSION="15.2"
ID="opensuse-leap"
ID_LIKE="suse opensuse"
VERSION_ID="15.2"
PRETTY_NAME="openSUSE Leap 15.2"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:15.2"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"

> plasmashell --version

plasmashell 5.18.6

Anything I can do?

It’s very annoying. It just started to happen a couple days ago…

Thank you

You mentioning “icons” I assume this is about a desktop environment. Can you please tel which DE this is about?

“elfroggio” has mentioned “plasmashell” – the Desktop GUI is KDE Plasma …

KDE Plasma System Settings – Hardware – Display and Monitor:

  • How do the 2 monitors appear in the Display setup?
  • Can you identify which is which?
  • Can you set-up the left-right order?
  • KDE with plasmashell 5.18.6
  • System settings | hardware | display and monitor | both monitor exactly next to each other with the left monitor: set as primary + replica of none. The right monitor: just enabled (NOT primary) + replica of none
  • Clicking on the identify, it does the proper identity: LG IPS231 left and Asus PB238 right
  • left-right order: Sorry, but I do not understand what you mean.

Thank you

In System Settings, you can drag the monitor to reflect it’s physical placement – for example, when presenting with a Laptop, the video projector “monitor” can be placed to be “above” the Laptop’s monitor …
[HR][/HR]Do you have the Plasmoid for the Monitor/Display/Screen set-up installed?
Do you have the X11 monitor configuration properly set-up?

  • /etc/X11/xorg.conf.d/50-monitor.conf

Section "Monitor"
  Identifier "HDMI1"
  Modeline "1920x1080_60.00"  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync
  Option "PreferredMode" "1920x1080_60.00"
  Option "RightOf" "HDMI2"
  Option "DPMS" "true"
EndSection

Section "Monitor"
  Identifier "HDMI2"
  Modeline "1920x1080_60.00"  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync
  Option "PreferredMode" "1920x1080_60.00"
  Option "LeftOf" "HDMI1"
  Option "DPMS" "true"
EndSection

Taken from this ArchLinux thread – <KDE - Dual monitor not working properly / Applications & Desktop Environments / Arch Linux Forums;

I didn’t do any change. Every evening I turn off the computer. The next morning, turn it on and the desktop icons were on the right screen instead of the left screen

Do you mean widgets? I only have the cpu/memory/swap and networking widgets installed

I didn’t do any xx-monitor.conf. It’s been running for a while without problem. I wil check into it.

Thanks