Desktop Icons Dissapear w/ higher Screen resolution

New linux install Leap 15.1 / KDE desktop
Older Dell machine Dimension 5100 w/ a Pentium 4 / 1.5 RAM (8MB dedicated to video card in BIOS)

Desktop: KDE
Displaying Desktop folder vs widgets

My Desktop icons weren’t displaying. However the icon descriptive text shows, and when I click on a desktop icon to drag / relocate it the desktop icon shows. When I release it disappears again. Also the upper right menu shows as a rectangle w/ cut corners vs the hamburger menu.

  • When I decrease my screen resolution to: 1152 x 864 the desktop icons appear as well as the upper right menu
  • Setting resolution to 1280 x 1024 or 1600 x 1200 the icons disappear.

Now for the weirder part:

  • If I set my desktop resolution to: 1152 x 864 and restart the icons show as expected, I am also able to open the display manager and set the higher resolutions (1280 x 1024 or 1600 x 1200) the icons still show and I’m able to work normally.
  • however if I restart when set to either of the higher resolutions the the icons again disappear and won’t reappear until I set the resolution back to 1152 x 864

The monitor and card are clearly able to handle the resolution, I can’t figure out why the restart messes it all up unless I scale back; only after starting in the mode can i go to a higher res.

Any thoughts?

Try disabling compositing in video settings.

Too small video memory.
Possible you have problems with a too old video chip.
Try to use newer video card, ATI or AMD if you prefer older graphics.

False. 8MB is the minimum reservation from system memory for video by the BIOS. The X driver will use as much additional system memory as it takes to support 1920x1200 @ 24 colors.

Possible you have problems with a too old video chip.
The northbridge chipsets that support 64 bit Pentium 4s are not too old. I have at least one running 15.1 with no apparent trouble, though Plasma I don’t run on it/them, which run KDE3 or TDE.

If disabling compositing doesn’t solve the problem, next I’d try logging out of Plasma, logging in on a vtty, and deleting the content of ~/.cache/. I’d also ensure all available updates are applied before logging into Plasma again. I’d also try reseating the RAM sticks, followed by an overnight run of memtest86. RAM can go bad. I’ve had probably a dozen RAM sticks from old Dells go bad.

Finally, that age Dimension is in a class of PCs subject to a high rate of electrolytic capacitor failures. It would do well to examine all motherboard caps for leakage and swelling. Only after I read this last reply several hours ago I tried to confirm my recollection of the video RAM issue on a Dell about 0-12 months older than a Dimension 5100, and it wouldn’t power up. I found 6 caps bad, replaced them, and was able to complete the verification using it, boot TW20191002, and upgrade successfully to TW20191122.

# xrandr | head -n5
Screen 0: minimum 8 x 8, current 1920 x 1200, maximum 32767 x 32767
VGA1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 520mm x 320mm
   1920x1200     59.95*+
   1920x1080     60.00
   1680x1050     59.95
# inxi -GxxSMC
System:    Host: gx280 Kernel: 5.2.14-1-default i686 bits: 32 compiler: gcc v: 9.2.1 Desktop: KDE 3 wm: kwin
           dm: N/A Distro: openSUSE Tumbleweed 20191122
Machine:   Type: Desktop System: Dell product: OptiPlex GX280 v: N/A serial: 4KZ4Z51 Chassis: type: 6
           serial: 4KZ4Z51
           Mobo: Dell model: 0G5611 serial: ..CN6986149919AC. BIOS: Dell v: A08 date: 03/03/2006
CPU:       Topology: Single Core model: Intel Pentium 4 bits: 32 type: MT arch: Netburst Prescott rev: 4
           L1 cache: 16 KiB L2 cache: 1024 KiB
           flags: pae sse sse2 sse3 bogomips: 11172
           Speed: 2793 MHz min/max: N/A Core speeds (MHz): 1: 2793 2: 2793
Graphics:  Device-1: Intel 82915G/GV/910GL Integrated Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
           chip ID: 8086:2582
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: fbdev,modesetting,vesa
           resolution: 1920x1200~60Hz
           OpenGL: renderer: Mesa DRI Intel 915G x86/MMX/SSE2 v: 1.4 Mesa 19.2.4 direct render: Yes

Thanks for the suggestions.

I’ve tried disabling the compositor; even performed a reboot, but the behavior remained the same.
Will try some of the other suggestions.

Thanks

You could have stumbled into the same error I posted a bug report a few years ago:

https://bugzilla.opensuse.org/show_bug.cgi?id=1062420

If you patch your FolderView.qml accordingly, does that make a difference?