desktop icon not showing up

If I drag a application icon from kickoff menu -programs to the desktop the application icon is not showing only a white paper flag.
But its is showing in the kickoff men -programs.
For example smplayer.

How to resolve this.

opensuse 11.4 x86_64 (KDE 4.6 )

Unlock widgets
Right click application in question > add to desktop

Lock widgets when done

widgets are not locked.
Thats not the problem.

Not drag and drop
Should work

You could try right clicking on the white paper icon select Icon settings>click the image square in the upper left> then pick an icon from the box that shows up. You can even select one of your choice by checking Other icons.

Open up your home folder, then open up the ‘Desktop’ folder. open the kickoff menu, navigate to the application you want on your desktop, and drag it to this folder. If you’re using Dolphin or Konqueror, a menu will pop up with a few options. You need to select create symlink. Done

Did all not work for me
I have changed to classic style menu then dragged the icons to the desktop and that worked.
Then I changed the classic menu back to default program starter
problem solved.

I sometimes find the same problem. All I do is right click on the icon which takes me to the icon options, click on the gear which takes me to the selection. Then I select the right one. Voila! rotfl!