.desktop file launching

Is there any way to configure kde so that it will launch applications via their **.**desktop files? They seems to be associated with kwrite.


I am afraid you will have to supply way more information than that. :frowning:

;)Having looked at what I had noticed more yes you do. The aspect I had noticed was down to a **.**desktop file from an xfce application that didn’t fully install. I am not running xfce but I liked the look of it.

However if I look in /usr/share/applications there are a lot of these files and if I click on any of them I am asked if I want to open or execute them. The open seems pointless as I can right click to do that.

I need to go back to the xfce application to explain why I asked the question. I couldn’t meet all of it’s dependencies so never installed it fully but did install an add to panel utility and that placed itself at the top of the **.**desktop file associations. All kde effectively offers there is open with kwrite so I wondered where the run or open association option is and why I can’t set it to just run them. This option should be there but isn’t but maybe it’s set somewhere else. If so I would like to know where.


Configure Desktop - Applications - File associations

If I look at **.**desktop associations there isn’t an option there that causes the current “open or run option” popup to run so it can’t be changed that way. It will still do that whatever is in associations. It defaults to what is in there when open is selected. I want these files to just run when clicked on.


You don’t associate with .desktop files you associate with the program that the .desktop files reference

Normally .desktops are just shortcuts to a program

So confused about what you expect

They are links to applications however if clicked I get asked if I want to open or run them. If I select open they then use their associations settings and open in kwrite.

I just want them to run without asking me first. There doesn’t seem to be anyway of getting them to do that.

I have looked at what can be associated with them, or any others but they don’t include anything that will cause them to just run.


I asked on a kde list. It seems this aspect on ???.desktop files is a regression. Translating it didn’t do this but now does. It’s been fixed in tumbleweed recently. The problem related to trusted files and maybe any file that doesn’t have an association as I have had the prompt on several different types of file.

The fix is pretty simple if needed. This is the user config folder.

   edit ~/.config/kiorc as the user not root.


It’s also possible to ask for confirm delete here as well. I have as I might delete an executable by mistake. I haven’t checked that this works but it should using =true rather than false.