Desktop Effects


I’m trying to enable both Alt + Tab cover flow & wobbly windows. Although there is a check mark against both, they are not in effect. I have an AMD APU with open source driver as Wiki does not recommend propriety driver for Tumbleweed?


Is the “Composite type” set to “OpenGL” on the “Advanced” tab in the Desktop Effects settings? Those effects might not work with XRender.

I have no idea if the open source radeon driver would work in your case.
Could you maybe install “Mesa-demo-x” and post the output of:

glxinfo | grep render

If not, your only choice is to install the proprietary driver. It’s not recommended on Tumbleweed because there are often kernel updates which would force you to reinstall the driver, but I guess you could set up DKMS for taking care of that. (I have no experience with that though)

Wobbly windows works when enabling OpenGL over XRender, not cover flow however. That is halfway there!


What is DKMS?

Is the Qt graphics system set to “raster” as well? That’s preferred with OpenGL.

Regarding “Cover Flow”: how exactly did you enable it?

You have to enable the effect in Desktop Effects and choose “Cover Switch” in Window Behaviour (“Task Switcher”->“Visualization”.)

Btw, this works fine on my old Radeon 9600 with the open source radeon driver.

What is DKMS?

DKMS is a system that automatically recompiles your kernel modules when necessary (i.e. after a kernel update).
See here:
A package is available on Packman.

Hmmm, strange.

I have checked the “Cover Switch” & “Flip Switch” boxes under Desktop Effects -> All Effects -> Window Management. Animating desktop switching with a cube works.

Yeah, right.
But again, you have to actually select it in “Window Behaviour”->“Task Switcher”:
Did you do that?

Do you get any error message regarding "Some Effects couldn’t be activated?

I hope you set the Composite setting to “OpenGL 2.0”. Those effects might not work with “OpenGL 1.2”.

Task Switcher aye? Who’d of thought a setting for that? I am learning my way round openSUSE but you the man! Beautiful! Using OpenGL 1.3, works perfectly.



I think you mean “OpenGL 1.2”? (there is no 1.3 backend AFAIK)

Consider switching to “OpenGL 2.0”. Your graphics chip and the radeon driver should support it.
The “OpenGL 1.2” backend is rather unmaintained (and even got dropped completely recently in upstream KDE).

I filed a request to update Mesa 3D driver from 9.2 to 10.x in Tumbleweed here:
please vote up to make it happen!**

It could reduce all kind of desktop-effect and gaming issues.