Desktop Effects

Because when launch a game program (Lbreakout2; Ltris, Torcs, …) in Opensuse 11.3 M 7, the composition “Desktop Effects” is automatically set as “Disabled” and the vision of game is not fluid?

This is my configuration:

hwinfo --gfx
23: PCI(AGP) 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
Unique ID: VCu0.AaUFnc8t2VE
Parent ID: vSkL.S16qDHSKEeD
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “ATI Radeon HD 3650 AGP”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x9596 “ATI Radeon HD 3650 AGP”
SubVendor: pci 0x1787 “Hightech Information System Ltd.”
SubDevice: pci 0x0028
Driver: “radeon”
Driver Modules: “drm”
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
I/O Ports: 0xa000-0xafff (rw)
Memory Range: 0xe9000000-0xe900ffff (rw,non-prefetchable)
Memory Range: 0xe8000000-0xe801ffff (ro,non-prefetchable,disabled)
IRQ: 16 (5057 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d00009596sv00001787sd00000028bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: radeonhd
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #11 (PCI bridge)

Primary display adapter: #23

If the problem is the video card driver, when in repository a new driver x-11-fglrx ( that in version for 11.2 is perfect) to test in the new 11.3 version?


Hope someone else (with ATI grahic) will answer as well.

Do not know much about ATI drivers but maybe you test also the newest compiz programms from factory (or from X11/compiz) and try to fiddle around with the configuration in the (bigger) compiz setting manager (“compizconfig-settings-manager : Compiz Config and Settings tool (CCSM)”).
In my case (problems with desktop effects and intel 915 graphic) it helped, see:

Good luck