Desktop effects, perpetual blank screen

I recently installed openSUSE for the first time in my laptop, an HP pavilion dv5, with 4 GB RAM, AMD Turion X2 64 bits, and an integrated ATI RADEON HD 3200 video card, and I was exploring it when I turned on Desktop Effects, if I recall correctly, and suddenly my screen flickered and then went blank and I couldn’t do anything; I shutdown my PC using the power button and when I logged back into my account I got the same blank screen. I was wondering if someone could help me a little here, I am not very familiar with linux.
I am using OpenSUSE 11.1 64 bits, with GNOME, by the way.


Sorry for my lousy english, non english speaker here

Hi SrEstroncio

Don’t apologise, you communicated your problem well. You’re going to need to edit /etc/X11/xorg.conf file. There will be a section like this:

Section “Extensions”
Option “Composite” “on”

You need to change it to this:

Section “Extensions”
Option “Composite” “Disable”

The best way to do this (since you have no working desktop) is probably to edit this from failsafe mode. The default commandline editors are not ‘newbie’ friendly. For this reason, I recommend you install pico editor. You will need to become root user first with ‘su’ command (enter root password when prompted). Then do:

zypper in pico

Once thats installed, you can back up your current xorg.conf like this:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.working

Edit this file (as root user):

pico /etc/X11/xorg.conf

It should be easy enough for you to navigate through this file, find the ‘Extensions’ section and make the change described above. Be careful with your editing though. When finished you can reboot, or simply type

init 5

to get your desktop back. Hope this works for you.

Another approach mentioned here.