Desktop effects not working in KDE 4.3.1 w/ GeForce 9500 GT

Hello all. First post and I’d like to start by thanking all here. Twelve years ago computers became necessary for my business. I knew, and now know marginally more than, nothing about computers, but I did know when I was paying through the nose for a half baked recycled piece of garbage. So I started building my own machines and running Linux. For the last ten years I’ve kept one isolated Windows machine that I need to run exactly one app on, and have relied entirely on Suse for everything else. Now I have three office machines, two notebooks, three machines for my three kids, and one for my wife, all running opensuse. And the only way I could have done it was by coming to this site. Literally hundreds of problems solved! You’ve no idea how much time I’ve spent lurking here. This one I can’t find an answer to.

Issue:
On this Box:

ASUS M4A785-M MB
AMD X4 965 CPU
NVidia GeForce 9500 GT GPU

Running:

opensuse 11.2 (x86_64)
KDE 4.3.1
NVidea drivers installed “the easy way”

I am unable to get the vast majority of desktop effects to work regardless of compositing type. Some do work, and in general 2D and 3D seem fine. Thanks for everything, past and future.

Which effects don’t work, and which do?

Did nvidia driver install write an /etc/X11/xorg.conf ? If so how does it look like ?
Is Xinerama on ? If so turn it off.
Is Composite off ? If so turn it on.

“Wobbly windows”, "minimize animation’, and to some degree “translucency”. Oddly, these work even with “Desktop Effects” disabled, but in any case nothing else works. Also, the “suspend Compositing” button doesn’t work.

Compositing can’t be turned off, neither clone or xinerama works, xorg is:

/…/

SaX generated X11 config file

Created on: 2009-12-09T08:24:07-0500.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “Module”
Load “extmod”
Load “dri”
Load “glx”
Load “dbe”
EndSection

Section “InputDevice”

Driver “kbd” will be disabled unless ‘Option “AutoAddDevices” “off”’

is set in “ServerFlags” section.

Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”

Driver “mouse” will be disabled unless ‘Option “AutoAddDevices” “off”’

is set in “ServerFlags” section.

Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “7”
Option “Device” “/dev/input/mice”
Option “Name” “Omnidirectional Control USB to PS2 Adaptor V2.50”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
Option “CalcAlgorithm” “XServerPool”
DisplaySize 352 264
HorizSync 30-96
Identifier “Monitor[0]”
ModelName “SAMSUNG SYNCMASTER”
Option “PreferredMode” “1280x1024”
VendorName “SAM”
VertRefresh 50-160
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
Modeline “1280x1024” 157.00 1280 1344 1504 1728 1024 1025 1028 1072 +HSync +VSync
Modeline “2560x1024” 157.50 2560 1344 1504 1728 1024 1025 1028 1072
EndSection

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
EndSection

Section “Device”
BoardName “GeForce 9500 GT”
Driver “nvidia”
Identifier “Device[0]”
Option “SaXDualHead”
Option “TwinView”
Option “SaXDualMonitorVendor” “VSC”
Option “SecondMonitorHorizSync” “31-70”
Option “SaXDualVSync” “50-160”
Option “MetaModes” “1280x1024,1280x1024;1280x960,1280x960;1280x800,1280x800;1152x864,1152x864;1280x768,1280x768;1280x720,1280x720;1024x768,1024x768;1280x600,1280x600;1024x600,1024x600;800x600,800x600;768x576,768x576;640x480,640x480”
Option “SaXDualOrientation” “RightOf”
Option “SaXDualResolution” “1280x1024”
Option “TwinViewOrientation” “RightOf”
Option “SaXDualMode” “Xinerama”
Option “SecondMonitorVertRefresh” “50-160”
Option “SaXDualHSync” “31-70”
Option “SaXDualMonitorModel” “VIEWSONIC”
Screen 0
VendorName “NVidia”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
Option “Composite” “on”
EndSection

I see only one monitor but your graphic device is configured for dualhead. If you have only one monitor, you can comment out all lines starting with “Option” in the device section.

The Option “SaXDualMode” “Xinerama” may be causing the problem.

There are two monitors, and both cloned display and xinerama work. Even with “Dual Disply” disabled, no desktop effects.

I notice that your xorg.conf was created today - did you have one before? The reason I ask is that as a long time Suse user, you are probably used to using Sax2 after installing the nvidia driver. But, as of 11.2, it’s no longer necessary - all you should need to do is restart your session after installation and things should work fine. I’m wondering if OpenSUSE is simply designed to work better without an xorg.conf file. Have you tried this already?

I suspect Xinerama is the one preventing desktop effects to work as expected. The solution would be not to use Xinerama at all and use Xrandr for dualhead. But I read in another thread that nvidia doesn’t have support for Xrandr (?). You should try to disable Xinerama for testing.

Section “Extensions”
Option “Composite” “on”
EndSection

Hei, I had a similar problem and solved it by editing x.org like this:

Section “Extensions”
Option “Damage” “true”
Option “Composite” “true”
EndSection

Should be worth a try and shouldn’t cause any problems if it doesn’t work.

Cheers

The timestamp on that xorg corresponds to my having made some changes in Sax2 this AM, specically changing xinerama to cloned display and then disabling dualhead when that didn’t help. Neither made a difference. Now I’m on the road with a lap running 10.2, so trying a restart after renaming /ect/x11/xorg.conf will have to wait 'til PM. Worst case: I get to learn or relearn how to get x started without a GUI.

Allright, I realized on the road I had a 64bit opensuse DVD with me, so I just made another partition and installed it on the lap I had with me. I did not install any nvidia drivers. No xorg.conf file. Desktop effects worked fine, within the limits of the low end and old GPU. I start SaX2, just to make changes to save, save them and get an xorg.conf file and desktop effects don’t work. Rename xorg.conf, restart, and all is well again. I think I’m fixed, but get home and on the machine in question, rename xorg.conf and restart. No desktop effects, but I get a message that another app has disabled compositing. Under the general tab of configure desktop settings, at the top, I now has a message that says compositing is not possible on this system as I lack X modules “composite” and “Damage”. And I have no more dualhead. When I try to configure NVidia server setting, it wants to save the changes to xorg.conf, which of course is no longer there. I’ve restored the xorg.cong files and got my dual head going again. I’m not sure what the problem is at all. After I post this I’m going to remove the nvidia drivers and see what things look like.

I have heard with certain nvidia cards that Kwin compositing is not so good.
If you have a working system though its possible to live without the desktop effects though it does make things a little less attractive.
You could however install Gnome, and use Compiz for effects.
I only suggest installing gnome as with the more recent versions of KDE compiz does not like to co operate.

Removing the Nvidia drivers did not go so well, and as fixing things from init3 would take me all weekend, I did a clean install.
Immediately after install I had an xorg file, and no desktop effects. Renamed xorg.conf and desktop effects worked. Installed nvidia drivers the brainless way and still had desktop effects. Couldn’t set up dualhead by configuring Nvidia server as it had no xorg.conf to write to, so I ran SaX2 and set it up from there (with xinerama); it of course made a new xorg.conf and both dualhead in xinerama mode and desktop effects worked.

Oddly, with the previous install that had been problematic, two desktop effects, “magic lantern minimize” and “wobbly windows”, had not only worked but had worked all through the process even regardless of whether they were were checkboxed or even whether desktop effects was enabled. In fact, they worked rather more dramatically than they do now. Having not yet gotten desktop effects to work properly, I didn’t understand this at the time.

I’ve saved all the xorg.conf files and will compare them later.

I’ve lost track now of what you’ve done and what works and what doesn’t but here are some general observations from my experience with NVIDIA, desktop effects, and dual monitors that might help:

  1. Ignore Sax2. Only use “nvidia-settings” as root to write xorg.conf. Never use the two together to write to the same xorg.conf.

  2. Xinerama and compositing don’t mix. Xinerama disables compositing.