Desktop effects have been suspended by another application

Yesterday, I switched my desktop system over from Leap 42.3 to Tumbleweed. Previously done my laptop and that worked fine, following instructions found here: (basically, swap out Leap repos for TW repos and zypper dup).
The only problem I have encountered on the desktop is with the NVidia card in the system, which worked fine under Leap. For some reason, desktop effects (KDE) keep getting suspended and using SHIFT+ALT+F12 doesn’t switch them on but instead immediately produces the same message again (desktop effects have been suspended by another application). It would be helpful if it included some hint about which application was doing it. I am also seeing strange artifacts in the notification tray, unreadable text in that area, etc. I could live without desktop effects but not without working notifications.

Troubleshooting steps by me
To test, I quickly made a second user account to see if the problem was with the settings stored in my profile somewhere. The desktop behaved the same way for thew new user.

I then verified if I had used the correct NVidia repository for TW. This looks fine to me:

I uninstalled and reinstalled the NVidia driver using the methods described on this page: (with reboots in between)
The problem remained the same.

Next, I thought I would give the Nouveau driver a go, to see if that had better results. Again, I removed the NVidia driver as per the instructions mentioned on the previous page, made sure the Nouveau driver wasn’t blacklisted somewhere in /etc/modprobe.d and rebooted. After this, my login manager only produced a black screen with a mouse cursor on one of the two attached monitors.

To at least get a working desktop again, I reinstalled the NVidia drivers. This brought the login manager and KDE back to life.

What I would like to do, is one of the following (in order of preference):

  1. Get the NVidia proprietary driver running correctly
  2. Switch to Nouveau but with a working desktop
  3. Switch back to Leap 42.3
  4. Reinstall Leap 42.3 from scratch

I would appreciate your suggestions about the best course of action and how to get there successfully. The switch back to Leap throws very worrying dependency errors with resolutions involving the removal of modules related to accessing encrypted disks. Since I run encrypted LVM, I’m not sure I want to go that route…

The card is:

hwinfo --gfxcard | grep Model
Model: "nVidia GK106 [GeForce GTX 645 OEM]"

If additional info is necessary, I will do my best to provide it of course. I’d appreciate your assistance since I am kind of stuck now. It’s been a while since I had to troubleshoot graphics drivers on openSUSE. :\

Am I understanding correctly that a reinstall of the nvidia driver brought back a working situation, i.e. with properly loaded nvidia driver, desktop effects OK etc.? AFAICT you should be OK from here then.

No, sorry for the confusion. I meant “working” as in, I can see the login manager, can log in and can work on the computer. Desktop effects are still not working, unless I switch the compositor to XRender. Then they are partially functional (I get transparancy on moving windows and drop shadows, etc). Things like cover switch or flip switch when I ALT+Tab don’t work.

Hope that clears things up!

Please disregard this thread. I reinstalled openSUSE Leap 42.3, with Nvidia proprietary driver after I ran into strange lockups with Tumbleweed. On Leap, the system is rock-solid again, Nvidia driver loaded and all.