Desktop effects failed after 1 month

I have been using SUSE 11 64 bit now for a month. Tonight I turn on my PC and none of my windows have an upper border and new windows open jammed up against the upper part of the screen where for some I can’t even see the menu bar so I have to use kill to close it. Thinking it was somehow maybe a corrupted user profile I created a new user and logged in and the problem was solved until I enabled desktop effects where it reappeared. So now I am back and logged in as me and I managed to turn off desktop effects but I rather enjoy them so is there some way to repair it?
I am using the Gnome desktop and desktop effects have been fine for the last month.
I did a shutdown -F now and that ran a fsck but did not fix the problem.
video card is a 256 MB nvidia 7300 GT.
Thanks for your help.

By effects, you mean Compiz??

It used to happen to me from time to time, when I was trying Compiz. Ctrl-Alt-Backspace to restart the desktop usually worked for me. It’s not a serious issue, more a bug in Compiz, so no need for disc checking.

Re-installed nividia drivers plus a lot of compiz stuff to no avail. I also installed simple CCSM which does not run when I click it and removed by “desktop effects” button in the control center. Looks like a re-install of the OS to me. I may wait for 11.1 to come out at this point.:frowning: