Desktop Effects && Compiz Fusion won't work.

Hey all,

I’ve been playing around wish SUSE for about a month now and I find it pretty appealing, but all those cool features of it, like desktop effects and Compiz Fusion are somehow unreachable for me. Everytime I try to enable the desktop effects, a dialog warning box indicates:

Desktop effects are not supported on your current hardware / configuration. Would you like to activate them anyway?

The only options I have are yes or no, If I choose no … of course … nothing happens. If I choose yes, some strange things happen. Sometimes the screen just gets blurry for a second and then it all goes back to normal, sometimes I get a black screen and really cannot do anything about it, have to shut off my machine from the BIOS. I have an HP laptop with an ATi 3200D video card in it. I know it’s not hell of a lot, but that’s all I could afford. I’m not sure if my video card is not good enough to produce video effects of this magnitude or my hardware is simply not available or not configured. Any help will be appreciated. Since I’ve done a lot of things with my gnome desktop already, i really want to step up and get my desktop effects working. That will make me feel even better about SUSE.

Thank you all. Thanks for the support.


Have you tried installing the non-free driver for your video card? I have an nVidia and had the same dialog box until I added the appropriate repository and installed the appropriate driver. Try here and here.
I just google “OpenSUSE ATI.” You may have been there already…

I’ve done it b4, The problem is pretty much solved, except the fact that I cannot install the proper driver. I can activate 3D, but all I see is … white screen :stuck_out_tongue: … I really gave up on Compiz Fusion long time ago. I can’t wait for 11.2, since they reported that this bug will be fixed once and forever.

Thanks for the reply btw, lol I almost forgot about this post;

Sorry to hear it didn’t work out.
I’m battling Compiz with my nVidia 8600 GTS right now as well.
Good luck!

Search for “ATI openSUSE” and you’ll find out how to get this working, cause it should work. Desktop effects, Compiz etc.

I would rather not… It’s probably just me, but I followed these steps so many times, and the moment I kill X, my SaX2 goes crazy :). I’m really not that interested in compiz anyways. Thanks for the suggestions, though.