desktop effects cant be activated

Hi, im using opensuse 11.2 with kde and im having problems to use desktop effects differents from those default ones. For exemple, I cant enable the desktop cube! i check the box and click apply… but nothing changes, even restarting the system. Maybe my graphics card is not working well… how can i fix it or discover if this is actually the problem?

first tell us your graphics card and if you have installed the drivers for it, then we can go from there. Also from a console, post the output of glxinfo | grep direct

I know that is an Intel series… i dont know the number :frowning:

this is what happened in terminal:

davi@linux-p657:~> glxinfo | grep direct
direct rendering: Yes

i didnt install any drivers, was hoping opensuse would do this to me :stuck_out_tongue:

Just activating the Cube is not enough. In Systemsettings - Desktop - Desktop-effects, please check whether compositing is enabled. I should say yes, since you say default effects work.

Now, in the first screen you also see an option for desktop switching, set it to use the Cube animation…AHA, there it is.

If the effect is activated you could also initiate the Cube with the shortcut Ctrl-F11. If that works, the AHA was in it’s place.

Please let us know if I understood well.

Knurpht, doing as you told me to do the cube is working ok! so, it means that the graphics card is configured? cause, for another exemple: the snow effect to desktop or the burning window effect…i select them, and nothing happens! what could cause this?

Hello everyone,

I have the same problem with my openSUSE 11.2 x86_64 version. I can’t enable any desktop effects at all.

Here’s my PC hardware brief view:

CPU - AMD Athlon 64 X2 4200+

M/B - Asus M2N4-SLI (nForce 500 chipset)

VGA - nVidia GeForce 9600 GT 256 bit 1Gb

When I’m checking my X11 configurations, it’s said that I’ve installed 9600GT video adapter (this means that suse had already installed the driver right?) and it has also installed my LCD monitor dirver Samsung 740N, but one strange thing, nelow the checkbox “enable 3D acceleration” is disabled but checked.

So, when I’m trying to change something in my desktop effect and apply it (for example just entire profile from default to advanced) I’m getting this error report:

Application: Simple CCSM (simple-ccsm-kde), signal: Segmentation fault
[KCrash Handler]
#5 0x00007fc035060761 in QAction::setChecked(bool) () from /usr/lib64/
#6 0x000000000041252b in _start ()

O.K. and one more thing, compositing is suspended and when I’m trying to resuming it, it does, but after I’m closing the configuration window and then run it again, there’s still the same.

Please help me to solve this problem, as it frustrates me, I’ve got an old IBM laptop, with integrated Intel graphics chipset and I’ve Ubuntu 9.10 installed on it, I’ve just change the desktop effects from performance mode to great visual mode and it works perfect. But I like SUSE, since I’m new in Linux, I’m trying to choose more acceptable Linux distribution for me and I think OpenSUSE is just perfect for me, but only I want that everything rocked on it, everythin that should worked by default, as i don’t think that I have something special hardware configuration that needs much sophisticated installation.

Thanks in advance.

Yep, the card is configured and working, otherwise no cube.

In the effects list, there’s options next to it. When enabled, they show the shortcuts and settings. To have snow over windows uncheck the according option.
Merely activating is not enough, otherwise it would be snowing all the time. For an instant blizzard hit Meta-Ctrl-F12. If it does not show, minimize all windows, or check settings of the effect.

Same story for other effects


It seems you’re trying to use compiz-fusion with KDE which is really highly unnecessary. Ubuntu uses GNOME so compiz fusion is reasonable there, but KDE has its own implementation of compiz that you can find by going to Configure Desktop (Personal Settings) then click on Desktop and Desktop Effects is the first category.

If you really want to use compiz with KDE4 I would suggest following this how-to guide:

Installing and Configuring Compiz - openSUSE Forums

If you have any more questions after following that guide feel free to ask.

Take Care,


Hi, thanks for reply and explanation, you’re right, I’d already noticed that Linux has a bunch of applications that actually implements the same task, hence the novice users like me are making this mistake and installing much similar applications with different names.

O.K. having comiz-fusion on my PC isn’t my “idea fix”, so if I do not need it on KDE desktop, I’ll uninstall it, I’m just interested, in case I’ll uninstall all the packages related to this compiz fusion, should everything work then? Is that why I have 3D acceleration checkbox disabled (but checked) in X11 configuration? and is that why my desktop composting suspends every time?

Oh, and one more thing, can you please tell me the packages I should uninstall? Should I uninstall just the packages related to compiz-fusion or all the packages that is related to compiz? Are the compiz and compiz-fusion definitely different applications/libraries?

Hello one more time.

I’ve deleted (uninstalled from YaST) evey package related to compiz. O.K. now when I’m going to Configure Desktop → Desktop Effects I see the same thing, my video composting is still temporarily disabled and when I’m trying to resume it, it’s useless. But I’ve find out one thing, when i’ve changed composting type from OpenGL to XRender, then the composting turn on and even some of the effects start to work, but with really poor performance, as it where some of oldest video adapters like S3 trio or something like this and it gives the message that some of the effect couldn’t be activated.

So what should I do? As it seems for me, I have some problems with OpenGL library, am I right? And if I’m right then how could I solve this problem? As can anyone tell me which packages I need to be capable fully run any OpenGL applications without trouble?

Thanks in advance.

Just to make sure you’ve added the driver repository could you please open up a terminal and copy and paste the output of:

zypper lr -d

Take Care,


Well, the problem is that I have no Internet connection at home, for some reasons it’s temporarily disconnected, so thats why I’m replying so late, I’m at my work place now and only at night, when I’ll arrive at home, I’m able to check your suggestions.

Here’s ons more suspicious thing, when I’m opening ‘My Computer’ in Konqueror were the hole system information is written, there’s said that my graphics card is nVidia 9600GT but in the driver section, it’s said that driver is unknown!!! So, maybe this is the problem? I thought that as soon as KDE and kernel had initialized the manufacturer and the model of my VGA, this means that it’s able to install the correct driver, but now as I see, this isn’t so, I think operating system just read the VGA information from its DMA and that’s all, maybe thats why it’s disabled activate 3D acceleration and that’s why I can’t run my desktop effects.

So, now I want to download nvidia drivers, bring it home and try to install them, but I have a little problem as I can’t understand which of the driver suites me from this list? ==>

I’ve decided to download this version - x11-video-nvidiaG02-190.53-9.1.x86_64.rpm as I saw on nvidia site, in Unix Drivers there was the latest version 190.53 on AMD platform, but I’m not sure ma I right or not? I have a problem also with hybernation, as after suspending the KDE, when I’m trying to resume my operating system from HDD, it hangs and does nothing, so as sleep and hybernation modes are related to Video Adapters, maybe the problem is in my VGA driver? What do you think?

Thanks for helping me.

Hello everyone,

I just want to say, that I’ve managed to solve this matter in the end. The whole problem was that I have no nVidia driver on my Linux. It seems that even if operating system does initialize you graphics card, if in the system information the driver version is Unknown, this means that you have no driver at all!!!

So, I’ve installed the latest nVidia driver and all the effect start working without any problem.

Thanks to all, who helped me with solving this matter.

Ah, right. Which is why I wanted to see your repository list.

All you have to do is add the nVidia repository to your repository list and Yast would have automatically chosen the right driver for you.

Glad you got it sorted out :slight_smile:

Take Care,


Check whether the driver is okay.