Desktop effects are not supported...

I have an ATI Radeon 9600 XT card. I’m sure this is good enough for desktop effects to be enabled on. Anyway I have installed the driver from the ATI website for linux. Now every time I try and enable desktop effects it just gives me the message:

Desktop effects are not supported on your current hardware / configuration. Would you like to activate them anyway?

I press yes but it just doesn’t enable it. I upgraded compiz. I used the 11.1 1-click thing. It all worked perfectly in 11.0 … I don’t understand what the problem is…

since 11.1 it has been giving me that message… Does anybody else have this problem?

Any ways to resolve it?

Many thanks!

I get the same message on this setup: nVidia Corporation, GeForce 6200. Driver: nvidia (3D-support, x11-video-nvidiaG02 177.82-1.1, nvidia-gfxG02-kmp-default 177.82_2.6.27.7_9.1-1.1).

Suspect it’s the driver. There are some other ones to try…

Is this in KDE 4?

I also had that problem after I’d installed the graphics card driver (nVidia). What I did was to set the profile to medium, and it’s worked without hassle. Give it a go.:slight_smile:

I’m in KDE3 (had 1st boot issue with KDE4 that in hindsight probably was just about screen order).

Trying “Medium” settings doesn’t make a difference.

Compiz worked fine yesterday when I still was in openSUSE 11.0 w/KDE3.

I’m in the GNOME environment.

I have tried all the options but nothing works. I had no problems whatsoever in 11.0 :frowning:

What happened? I miss the desktop effects! :’(

richyf89 wrote:

> I’m in the GNOME environment.
> I have tried all the options but nothing works. I had no problems
> whatsoever in 11.0 :frowning:
> What happened? I miss the desktop effects! :’(

Check your xorg.conf in /etc/X11/ you will need:


Section “Extensions”
Option “Composite” “On”


At the end to enable the composite.

That should do it.



Nil illegitimi carborundum

Hiya, Thanks for the suggestion but it didn’t work.

Compiz showed up on the list of updates today. So I updated it. It seems desktop effects turn on now. They stay on, but just don’t work. There are 0 effects actually working.

Perhaps its a bug they are working on…

Are You guys using the correct Compiz repository?? As a hint i’ll tell You it’s not the one that YaST shows in community repositories;)

I definitely am using that repo.

It really sounds like a driver issue to me. I had same thing happen, but with my Nvidia card…

Do you get any 3d acceleration at all? or is your only problem with desktop effects not working?

I think your right because google earth just doesn’t work and the catalyst control center is a bit messed up in the 3d section.

I can’t really see much happening on the ATI opensuse page… Do you think we need to wait for a fix?

I found this on the forums:

ATI driver for 11.1 openSuSE - openSUSE Forums

“There may be problems with the driver, caused by the new kernel version, 2.6.27 used in 11.1; if that’s the case then you’ll have to wait until ATI release in January, or someone’s found a work round, or patches go into SuSE kernel.” ~robopensuse

try removing your old compiz config dir.

logout and log back in then try and enable the desktop-effects

I think there’s a dir like that some where in kde but not sure of location.

could be located in .kde dir, sorry not real good with kde these days.

Bummer :-/

I have the same problem, using KDE 3.5.10 release 20.11 and Intel 965G graphics card.
Everything was working great on SuSE 11.0, I think was a big mistake the update to 11.1 too many bugs. Nothing work

I feel your pain!

I was really excited to update, It seems like we all made the same mistake! :open_mouth:

I don’t even think I can watch videos properly, they are so laggy and unwatchable… It must be a driver problem like the guys said.

I’ll tell you what richyf89…
I fix the compiz problem here:
Compiz Fusion - openSUSE
for the version 11.1
Now emerald is the pain, I don’t have window frames. GRRR !!!
I saw several people with same problems here in the forums with emerald. Just we have to continue fixing this big mess.
BTY, about multimedia well another nightmare for me, after the update all my multimedia programs were deleted, smplayer, VLC, realplayer, XMMS even the codecs. Now I have to reinstall each one of them.
This update 11.1 killed my weekend.

Have you added this section composite is on in your xorg.conf?

Section “Extensions”
Option “Composite” “On”

I added this. Is that right? Is there anything more you need to do after adding this to the xorg.conf file?