Desktop Effects and double click on titlebar

With Dektops Effects enabled the double click on a titlebar of an application doesn’t maximize the window. How can I change this behavior? :\


If you are using Emerald, go to Emerald Theme Manager and in the second tab that says Emerald Settings select “Maximize” instead of “Shade” from the drop-down menu.

I’m using Compiz (openSUSE 11.1 with Gnome). How can I change the behavior with Compiz?

Well, Compiz is a window manager and Emerald is a window decorator.

If you’re not using Emerald then you must be having Metacity as window decorator. Its the default one in Gnome.

Just go to Control Center → Windows and set “Maximize” there.

The “Titlebar Action” in Window Preferences is already set to “Maximise”. Actually the double click is working when Desktop Effects are disabled - but after enabling the double click doesn’t work anymore.

I’m using a “normal” openSUSE 11.1 with Gnome - what is the standard window manager and window decorator in openSUSE 11.1?

The default window decorator in 11.1 is Metacity but a lot of people use Emerald because its eye candy.

I dont know what might be the problem.

To have Emerald just install “compiz-emerald” and “compiz-emerald-themes” packages in YaST.

Then press Alt+F2 and type “emerald --replace”. You should notice new titlebar.

To change themes and settings go to Control Center → Emerald Theme Manager.

More Emerald themes here: - Beryl Emerald Themes

Hi there,

I have the same problem as described above. It worked fine in OpenSuse 11.0 with Compiz. But in 11.1 it only works when Compiz is disabled…

No solution??

I reported this in Bugzilla (462513), but it has a very low priority

I have the same problem (11.1). It works when desktop effects are disabled but it fails when it is enabled. (Both Metacity and Emerald)
If my investigation gives any results I will post them here. :wink:

Any news about this problem?