Desktop Crashes and Hard Locks After New Install of 12.3

I installed openSUSE 12.3 sometime last week. Ran all updates. Things seemed fine for a few days. Then suddenly within 24 hours I had two desktop crashes, where the desktop reloaded itself immediately. Apps kept chugging along, so I wasn’t TOO concerned.

Then yesterday while playing back videos of TV shows in VLC I had two hard lockups within half an hour. Since I was downloading a 1GB file via Firefox at the top this was annoying as hell. The system was completely frozen and required a hard boot. Clearly there is an issue with the video subsystem.

Remember this is a new clean install on a new hard drive plus all current updates.

Last year with 12.2 I had problems with excessive Xorg CPU consumption. I was never able to figure out the problem as indicated here:

However, with the 12.3 install, all this seemed to go away: I no longer had issues with Firefox freezing for 10-20 seconds on image downloads, and there was no indication of excessive Xorg CPU use. Since I’m running the default nouveau drivers, I am loathe to convert to the proprietary Nvidia drivers since that was what I was running in 12.2. However, last year the nouveau drivers were crashing the system on video playback. If there is still a problem with them this year causing the current crashes, I suppose I’ll have to switch back to the proprietary ones.

So the question really is: What drivers should I use for an NVidia GeForce 9800 GT running on an AMD system with an ASUS M3N78 PRO mobo? Will the nouveau work (once the current problem is fixed, if it can be fixed) or should I dump nouveau and run proprietary? And if I run proprietary, should I use the opensuse nvidia repositories and YAST or the current NVidia driver from the NVidia Web site?

My system info is as follows:

System:    Host: Kernel: 3.7.10-1.16-desktop x86_64 (64 bit) 
Desktop: KDE 4.10.5 Distro: openSUSE 12.3 (Dartmouth)
Machine:   Mobo: ASUSTeK model: M3N78 PRO version: 1.XX Bios: Phoenix version: ASUS M3N78 PRO 0403 date: 08/26/2008
CPU:       Quad core AMD Phenom 9650 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) 
              Clock Speeds: 1: 1150.00 MHz 2: 2300.00 MHz 3: 1150.00 MHz 4: 1150.00 MHz
Graphics:  Card: NVIDIA G92 [GeForce 9800 GT] 
              X.Org: 1.13.2 drivers: nouveau (unloaded: fbdev,nv,vesa) Resolution: 1600x900@60.0hz 
             GLX Renderer: Gallium 0.4 on NV92 GLX Version: 3.0 Mesa 9.0.2
Audio:    Card: NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio driver: snd_hda_intel 
Sound: Advanced Linux Sound Architecture ver: k3.7.10-1.16-desktop
Network:   Card: NVIDIA MCP77 Ethernet driver: forcedeth 
               IF: eth0 state: up speed: 100 Mbps duplex: full
Drives:    HDD Total Size: 5001.0GB (38.0% used) 1: id: /dev/sda model: TOSHIBA_DT01ACA2 size: 2000.4GB 
              2: id: /dev/sdb model: WDC_WD1001FALS size: 1000.2GB 3: USB id: /dev/sdd model: My_Book_1130 size: 2000.4GB 
Partition: ID: / size: 15G used: 8.7G (62%) fs: ext4 ID: /home size: 15G used: 1.1G (8%) fs: ext4 
              ID: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 161 Uptime: 1:19 Memory: 1492.2/3959.5MB Client: Shell (bash) inxi: 1.9.7 

Linux 3.7.10-1.16-desktop #1 SMP PREEMPT Fri May 31 20:21:23 UTC 2013 (97c14ba) x86_64 x86_64 x86_64 GNU/Linux

00:00.0 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
00:01.0 ISA bridge: NVIDIA Corporation MCP78S [GeForce 8200] LPC Bridge (rev a2)
00:01.1 SMBus: NVIDIA Corporation MCP78S [GeForce 8200] SMBus (rev a1)
00:01.2 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:01.3 Co-processor: NVIDIA Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
00:01.4 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:02.0 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:06.0 IDE interface: NVIDIA Corporation MCP78S [GeForce 8200] IDE (rev a1)
00:07.0 Audio device: NVIDIA Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
00:08.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:09.0 IDE interface: NVIDIA Corporation MCP78S [GeForce 8200] SATA Controller (non-AHCI mode) (rev a2)
00:0a.0 Ethernet controller: NVIDIA Corporation MCP77 Ethernet (rev a2)
00:10.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:12.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:13.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:14.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:0a.0 FireWire (IEEE 1394): LSI Corporation FW322/323 [TrueFire] 1394a Controller (rev 70)
02:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev a2)

#  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                                         | Service
 1 | Java                      | Java                               | Yes     | Yes     |   99     | rpm-md |                     |        
 2 | KDE_Extra                 | KDE Extra                          | Yes     | Yes     |   99     | rpm-md |                         |        
 3 | KDE_Updated_Apps          | KDE Updated Apps                   | Yes     | Yes     |   99     | rpm-md |                   |        
 4 | Mozilla                   | Mozilla Firefox                    | Yes     | Yes     |   99     | rpm-md |                            |        
 5 | Packman_Essentials        | Packman Essentials                 | Yes     | Yes     |   99     | rpm-md |                                       |        
 6 | Packman_Multimedia        | Packman Multimedia                 | Yes     | Yes     |   99     | rpm-md |                                       |        
 7 | Security                  | Security                           | Yes     | Yes     |   99     | rpm-md |       |        
 8 | WINE                      | WINE                               | Yes     | Yes     |   99     | rpm-md |                    |        
 9 | openSUSE_12.3_ISO         | openSUSE 12.3 ISO                  | Yes     | No      |   99     | yast2  | iso:///?iso=openSUSE-12.3-DVD-x86_64.iso&url=file:///LinuxData2/LinuxPrograms2/OpenSUSEISO/ |        
10 | repo-debug                | openSUSE-12.3-Debug                | No      | Yes     |   99     | NONE   |                              |        
11 | repo-debug-update         | openSUSE-12.3-Update-Debug         | No      | Yes     |   99     | NONE   |                                             |        
12 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   |                                     |        
13 | repo-non-oss              | openSUSE-12.3-Non-Oss              | Yes     | Yes     |   99     | yast2  |                                |        
14 | repo-oss                  | openSUSE-12.3-Oss                  | Yes     | Yes     |   99     | yast2  |                                    |        
15 | repo-source               | openSUSE-12.3-Source               | No      | Yes     |   99     | NONE   |                             |        
16 | repo-update               | openSUSE-12.3-Update               | Yes     | Yes     |   99     | rpm-md |                                                   |        
17 | repo-update-non-oss       | openSUSE-12.3-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md |                                           |        

INITRD_MODULES="pata_amd ata_generic"
DOMU_INITRD_MODULES="xennet xenblk"

I’ve seen a couple of KDE desktop crashes also . Seems to be a high memory usage condition. This seems to happen to me with a Vbox VM running and trying to do some high memory task in the KDE desktop. My VM is 512 meg and I only have 2 gig memory. Interestingly the VM kept running even while KDE crashed :slight_smile:

This started happening after the KDE update a few weeks back. Though prior to that I had Firefox crash several times while running a VM, But not the desktop. So there may be some memory problem but I still have plenty of swap when it happened

BTW I’m running the NVIDIA driver so ot is not a driver problem

For awhile now, when I think I might be pushing the resources of my system,

I run the KDE Desktop widget “Memory Status”
I open a standing console and run free periodically in it to update current usage.

Note this would tell you if you have a memory pressure/exhaustion/usage problem. If your readings aren’t consistent with crashes, then I’d next suspect a resource heap problem and for that you should consider all the apps you’re running.


Well, it’s beginning to look like it might be a resources problem.

What I usually have open is the following:

  1. Dolphin.
  2. Exaile for music playing - not usually actually playing anything, however.
  3. VLC for videos - not usually actually playing anything.
  4. Chromium Web browser as my Twitter interface.
  5. jEdit editor.
  6. Adobe PDF Reader holding open my passwords list.
  7. Firefox.

Yesterday and today, Firefox has repeatedly locked up, hitting 75-100% CPU. Just now it locked up again after heavy use for downloading images from Fansshare. (As an aside, I discovered yesterday that Fansshare runs, a URL linker run by Radiumone - this causes dozens of IP connections apparently dependent on how many images you download - and if you block with NoScript, the image menus don’t work.) Anyway, I checked with top, and there was no high CPU load. Instead, almost all of my 4GB of memory was in use - only 900K free. I killed Firefox using the alternate console and recovered about a gig of memory. I decided to reboot the system after returning to the main session - and the desktop locked up. I had to use the alternate console again to reboot the system.

Clearly openSUSE 12.3 has some serious issues with either Firefox or memory management or my video card or something. My normal usage as listed above never generated this level of problems in the past. If this continued degradation of openSUSE from release to release continues, I may have to switch distros. This is just unacceptable and ridiculous. Do I have to run a system with 16GB of RAM and a Core i7 just to run Linux now?

I think what I will do is restart Firefox more frequently. I have a suspicion that there are still tons of memory leaks in that POS which Mozilla will never get around to fixing, obsessed as they are with new no-one-asked-for-them features… I’ll also take tsu2’s advice and run free often to see what is happening.

try without the Adobe PDF Reader another good place for memory corruption There are other PDF readers